
CVE catalog
CVE-2019-1010182
rust-yaml-rust: CVE-2019-1010182
- Severity
- Low
- Source
- [NVD] · [CVE record]
- EPSS
- 1.06% · Oct 25, 2026
yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rust-yaml-rust | bookworm | 0.4.5-1 | not affected |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rust-yaml-rust | source | bookworm | Not affected | unimportant | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [librust-yaml-rust-dev]Not affected
Source package: [rust-yaml-rust]
Details (2)
0.4.5-1+b1· amd64 · bookwormNot affected
dsa · rust-yaml-rust · debian · bookworm
0.4.5-1+b1· arm64 · bookwormNot affected
dsa · rust-yaml-rust · debian · bookworm
Observed: