CVE catalog

CVE-2019-10774

php-shellcommand: CVE-2019-10774

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.63% · Oct 25, 2026

php-shellcommand versions before 1.6.1 have a command injection vulnerability. Successful exploitation could lead to arbitrary code execution.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphp-shellcommandsid1.7.0-2fixed
Debianphp-shellcommandforky1.7.0-2fixed
Debianphp-shellcommandtrixie1.7.0-2fixed
Debianphp-shellcommandbookworm1.6.4-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphp-shellcommandsourcesid1.6.1-1not yet assignedNot reportedNot reported
Debianphp-shellcommandsourceforky1.6.1-1not yet assignedNot reportedNot reported
Debianphp-shellcommandsourcetrixie1.6.1-1not yet assignedNot reportedNot reported
Debianphp-shellcommandsourcebookworm1.6.1-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.6.4-2 · all · bookworm

      Fixed · Fixed: 1.6.1-1

      dsa · php-shellcommand · debian · bookworm; dsa · php-shellcommand · debian · 12

    • 1.6.4-2 · all · bookworm

      Fixed · Fixed: 1.6.1-1

      dsa · php-shellcommand · debian · bookworm; dsa · php-shellcommand · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.7.0-2 · all · trixie

      Fixed · Fixed: 1.6.1-1

      dsa · php-shellcommand · debian · 13

    • 1.7.0-2 · all · trixie

      Fixed · Fixed: 1.6.1-1

      dsa · php-shellcommand · debian · 13

Observed:

References