
CVE catalog
CVE-2019-11253
kubernetes: CVE-2019-11253
- Severity
- High · CVSS 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 25.94% · Oct 25, 2026
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | kubernetes | sid | 1.36.4+ds-1 | fixed |
| Debian | kubernetes | forky | 1.36.4+ds-1 | fixed |
| Debian | kubernetes | trixie | 1.32.3+ds-2 | fixed |
| Debian | kubernetes | bookworm | 1.20.5+really1.20.2-1.1+deb12u1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | kubernetes | source | sid | 1.17.4-1 | not yet assigned | Not reported | Not reported |
| Debian | kubernetes | source | forky | 1.17.4-1 | not yet assigned | Not reported | Not reported |
| Debian | kubernetes | source | trixie | 1.17.4-1 | not yet assigned | Not reported | Not reported |
| Debian | kubernetes | source | bookworm | 1.17.4-1 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [kubernetes-client]Fixed
Source package: [kubernetes]
Details (2)
1.20.5+really1.20.2-1.1+deb12u1· amd64 · bookwormFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · bookworm; dsa · kubernetes · debian · 12
1.20.5+really1.20.2-1.1+deb12u1· arm64 · bookwormFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · bookworm; dsa · kubernetes · debian · 12
[Debian 13 (Trixie)]
- [golang-k8s-kubectl-dev]Fixed
Source package: [kubernetes]
Details (2)
1.32.3+ds-2· all · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
1.32.3+ds-2· all · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
- [kubectl]Fixed
Source package: [kubernetes]
Details (2)
1.32.3+ds-2· amd64 · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
1.32.3+ds-2· arm64 · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
- [kubernetes-client]Fixed
Source package: [kubernetes]
Details (2)
1.32.3+ds-2· amd64 · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
1.32.3+ds-2· arm64 · trixieFixed · Fixed:
1.17.4-1dsa · kubernetes · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_10901-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2019-11253]
- [https://security-tracker.debian.org/tracker/CVE-2019-11253]
- [https://security.access.redhat.com/data/csaf/v2/vex/2019/cve-2019-11253.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2020/wid-sec-w-2026-0777.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]