CVE catalog

CVE-2019-17560

netbeans: CVE-2019-17560

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
2.32% · Oct 25, 2026

The "Apache NetBeans" autoupdate system does not validate SSL certificates and hostnames for https based downloads. This allows an attacker to intercept downloads of autoupdates and modify the download, potentially injecting malicious code. “Apache NetBeans" versions up to and including 11.2 are affected by this vulnerability.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannetbeanssid12.1-3fixed
Debiannetbeansforky12.1-3fixed
Debiannetbeanstrixie12.1-3fixed
Debiannetbeansbookworm12.1-3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannetbeanssourcesid12.1-1unimportantNot reportedNot reported
Debiannetbeanssourceforky12.1-1unimportantNot reportedNot reported
Debiannetbeanssourcetrixie12.1-1unimportantNot reportedNot reported
Debiannetbeanssourcebookworm12.1-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [netbeans]

    Details (2)
    • 12.1-3 · all · bookworm

      Fixed · Fixed: 12.1-1

      dsa · netbeans · debian · bookworm; dsa · netbeans · debian · 12

    • 12.1-3 · all · bookworm

      Fixed · Fixed: 12.1-1

      dsa · netbeans · debian · bookworm; dsa · netbeans · debian · 12

[Debian 13 (Trixie)]

  • Source package: [netbeans]

    Details (2)
    • 12.1-3 · all · trixie

      Fixed · Fixed: 12.1-1

      dsa · netbeans · debian · 13

    • 12.1-3 · all · trixie

      Fixed · Fixed: 12.1-1

      dsa · netbeans · debian · 13

Observed:

References