CVE catalog

CVE-2019-17596

UBUNTU-CVE-2019-17596

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Updated
Source
[NVD] · [CVE record]
EPSS
4.69% · Oct 27, 2026

Go before 1.12.11 and 1.3.x before 1.13.2 can panic upon an attempt to process network traffic containing an invalid DSA public key. There are several attack scenarios, such as traffic from a client to a server that verifies client certificates.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangolang-1.11101.11.6-1vulnerable
Debiangolang-1.11101.11.6-1+deb10u1vulnerable
Debiangolang-1.11101.11.6-1+deb10u2vulnerable
Debiangolang-1.11101.11.6-1+deb10u3fixed
Opensusenotarytumbleweed0.7.0-1.2fixed
Ubuntugolang-1.1014.041.10.4-2ubuntu1~14.04.1vulnerable
Ubuntugolang-1.1016.041.10.4-2ubuntu1~16.04.1vulnerable
Ubuntugolang-1.1016.041.10.4-2ubuntu1~16.04.2vulnerable
Ubuntugolang-1.616.041.6-0ubuntu1vulnerable
Ubuntugolang-1.616.041.6-0ubuntu2vulnerable
Ubuntugolang-1.616.041.6-0ubuntu3vulnerable
Ubuntugolang-1.616.041.6-0ubuntu4vulnerable
Ubuntugolang-1.616.041.6-0ubuntu5vulnerable
Ubuntugolang-1.616.041.6.1-0ubuntu1vulnerable
Ubuntugolang-1.616.041.6.2-0ubuntu5~16.04vulnerable
Ubuntugolang-1.616.041.6.2-0ubuntu5~16.04.2vulnerable
Ubuntugolang-1.616.041.6.2-0ubuntu5~16.04.3vulnerable
Ubuntugolang-1.616.041.6.2-0ubuntu5~16.04.4vulnerable
Ubuntugolang-1.1018.041.10~rc1-1vulnerable
Ubuntugolang-1.1018.041.10~rc1-1ubuntu1vulnerable
Ubuntugolang-1.1018.041.10~rc1-2ubuntu1vulnerable
Ubuntugolang-1.1018.041.10~rc2-1ubuntu1vulnerable
Ubuntugolang-1.1018.041.10-1ubuntu1vulnerable
Ubuntugolang-1.1018.041.10.1-1ubuntu2vulnerable
Ubuntugolang-1.1018.041.10.4-2ubuntu1~18.04.1vulnerable
Ubuntugolang-1.1018.041.10.4-2ubuntu1~18.04.2vulnerable
Ubuntugolang-1.818.041.8.3-2ubuntu1vulnerable
Ubuntugolang-1.818.041.8.3-2ubuntu1.18.04.1vulnerable
Ubuntugolang-1.918.041.9.1-2ubuntu1vulnerable
Ubuntugolang-1.918.041.9.2-1ubuntu1vulnerable
Ubuntugolang-1.918.041.9.2-3ubuntu1vulnerable
Ubuntugolang-1.918.041.9.3-1ubuntu1vulnerable
Ubuntugolang-1.918.041.9.4-1ubuntu1vulnerable
Ubuntugolang-1.1320.041.13.1-1ubuntu1vulnerable
Ubuntugolang-1.1320.041.13.3-1ubuntu1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangolang-1.11deb101.11.6-1+deb10u3Not reportedDSA-4551-1Not reported
Opensusenotaryrpmtumbleweed0.7.0-1.2Not reportedOPENSUSE-SU-2024:11098-1Not reported
Ubuntugolang-1.13deb20.041.13.3-1ubuntu1Not reportedUBUNTU-CVE-2019-17596Not reported

OpenFactory catalog packages

[openSUSE Tumbleweed]

  • [notary]Fixed

    Source package: [notary]

    Details (1)
    • 0.7.0-2.10 · x86_64 · tumbleweed

      Fixed · Fixed: 0.7.0-1.2

      pypi · notary · opensuse · tumbleweed

Observed:

References