
CVE catalog
CVE-2019-20632
UBUNTU-
An issue was discovered in libgpac.a in GPAC before 0.8.0, as demonstrated by MP4Box. It contains an invalid pointer dereference in gf_odf_delete_descriptor in odf/desc_private.c that can cause a denial of service via a crafted MP4 file.
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.84% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian11 | gpac | 1.0.1+dfsg1-2 | Fixed | [DEBIAN-CVE-2019-20632] |
Showing 1 fix observations. All 4 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian11 | gpac | 1.0.1+dfsg1-2 | Fixed | [DEBIAN-CVE-2019-20632] |
| Ubuntupro | gpac | 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu1 | Affected | [UBUNTU-CVE-2019-20632] |
| Ubuntupro | gpac | 0.5.2-426-gc5ad4e4+dfsg5-5 | Affected | [UBUNTU-CVE-2019-20632] |
| Ubuntupro | gpac | 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2 | Affected | [UBUNTU-CVE-2019-20632] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "gpac",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1+dfsg1-2"
}
]
}
],
"release": "11",
"versions": [],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-20632",
"fixed_version": "1.0.1+dfsg1-2",
"provider_source": "pypi",
"provider_record_id": "DEBIAN-CVE-2019-20632",
"provider_updated_at": "2026-08-29T07:02:46.762721326Z"
},
{
"name": "gpac",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"0.5.2-426-gc5ad4e4+dfsg5-4ubuntu1",
"0.5.2-426-gc5ad4e4+dfsg5-5",
"0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-20632",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2019-20632",
"provider_updated_at": "2026-04-22T12:17:27.881910Z"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: