
CVE catalog
CVE-2019-20805
UBUNTU-
p_lx_elf.cpp in UPX before 3.96 has an integer overflow during unpacking via crafted values in a PT_DYNAMIC segment.
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.82% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Ubuntu20.04 | upx-ucl | 3.95-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu20.04 | upx-ucl | 3.95-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-3 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-4 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu16.04 | upx-ucl | 3.91-1 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Debian14 | upx-ucl | 3.96-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-20805] |
| Debian13 | upx-ucl | 3.96-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-20805] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian13 | upx-ucl | 3.96-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-20805] |
| Debian14 | upx-ucl | 3.96-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-20805] |
| Ubuntu16.04 | upx-ucl | 3.91-1 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-3 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu18.04 | upx-ucl | 3.94-4 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu20.04 | upx-ucl | 3.95-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
| Ubuntu20.04 | upx-ucl | 3.95-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-20805] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "upx-ucl",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.96-1"
}
]
}
],
"release": "13",
"versions": [],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-20805",
"fixed_version": "3.96-1",
"provider_source": "pypi",
"provider_record_id": "DEBIAN-CVE-2019-20805",
"provider_updated_at": "2026-09-21T07:03:17.660776010Z",
"applicability_unknown": true
},
{
"name": "upx-ucl",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.96-1"
}
]
}
],
"release": "14",
"versions": [],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-20805",
"fixed_version": "3.96-1",
"provider_source": "pypi",
"provider_record_id": "DEBIAN-CVE-2019-20805",
"provider_updated_at": "2026-09-21T07:03:17.660776010Z",
"applicability_unknown": true
},
{
"name": "upx-ucl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"3.91-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-20805",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2019-20805",
"provider_updated_at": "2025-10-24T04:48:09Z",
"applicability_unknown": true
},
{
"name": "upx-ucl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"3.94-2",
"3.94-3",
"3.94-4"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-20805",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2019-20805",
"provider_updated_at": "2025-10-24T04:48:09Z",
"applicability_unknown": true
},
{
"name": "upx-ucl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "20.04",
"versions": [
"3.95-2",
"3.95-2build1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-20805",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2019-20805",
"provider_updated_at": "2025-10-24T04:48:09Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 13 (Trixie)]
- [upx-ucl]Unknown
Details (2)
4.2.4-1.1· amd64 · trixieFixed · Fixed:
3.96-1pypi · upx-ucl · debian · 13
4.2.4-1.1· arm64 · trixieFixed · Fixed:
3.96-1pypi · upx-ucl · debian · 13
Observed: