
CVE catalog
CVE-2019-25078
pacparser: CVE-2019-25078
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.45% · Oct 25, 2026
A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pacparser | sid | 1.5.1-1 | fixed |
| Debian | pacparser | forky | 1.5.1-1 | fixed |
| Debian | pacparser | trixie | 1.4.5-4 | fixed |
| Debian | pacparser | bookworm | 1.3.6-1.4 | fixed |
| Ubuntu | pacparser | 16.04 | 1.3.0-2 | vulnerable |
| Ubuntu | pacparser | 16.04 | 1.3.6-1 | vulnerable |
| Ubuntu | pacparser | 16.04 | 1.3.6-1.1 | vulnerable |
| Ubuntu | pacparser | 16.04 | 1.3.6-1.1build1 | vulnerable |
| Ubuntu | pacparser | 18.04 | 1.3.6-1.1build3 | vulnerable |
| Ubuntu | pacparser | 20.04 | 1.3.6-1.1build5 | vulnerable |
| Ubuntu | pacparser | 20.04 | 1.3.6-1.1build6 | vulnerable |
| Ubuntu | pacparser | 20.04 | 1.3.6-1.1ubuntu1 | vulnerable |
| Ubuntu | pacparser | 20.04 | 1.3.6-1.2 | vulnerable |
| Ubuntu | pacparser | 22.04 | 1.3.6-1.2build2 | vulnerable |
| Ubuntu | pacparser | 22.04 | 1.3.6-1.2build3 | vulnerable |
| Ubuntu | pacparser | 22.04 | 1.3.6-1.2ubuntu1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | pacparser | source | sid | 1.3.6-1.4 | not yet assigned | Not reported | [1026106] |
| Debian | pacparser | source | forky | 1.3.6-1.4 | not yet assigned | Not reported | [1026106] |
| Debian | pacparser | source | trixie | 1.3.6-1.4 | not yet assigned | Not reported | [1026106] |
| Debian | pacparser | source | bookworm | 1.3.6-1.4 | not yet assigned | Not reported | [1026106] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libpacparser1]Fixed
Source package: [pacparser]
Details (2)
1.3.6-1.4· amd64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
1.3.6-1.4· arm64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
- [libpacparser-dev]Fixed
Source package: [pacparser]
Details (2)
1.3.6-1.4· amd64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
1.3.6-1.4· arm64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
- [python3-pacparser]Fixed
Source package: [pacparser]
Details (2)
1.3.6-1.4· amd64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
1.3.6-1.4· arm64 · bookwormFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · bookworm; dsa · pacparser · debian · 12
[Debian 13 (Trixie)]
- [libpacparser1]Fixed
Source package: [pacparser]
Details (2)
1.4.5-4+b2· amd64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
1.4.5-4+b2· arm64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
- [libpacparser-dev]Fixed
Source package: [pacparser]
Details (2)
1.4.5-4+b2· amd64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
1.4.5-4+b2· arm64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
- [python3-pacparser]Fixed
Source package: [pacparser]
Details (2)
1.4.5-4+b2· amd64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
1.4.5-4+b2· arm64 · trixieFixed · Fixed:
1.3.6-1.4dsa · pacparser · debian · 13
Observed: