
CVE catalog
CVE-2019-5421
ruby-devise: CVE-2019-5421
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.56% · Oct 25, 2026
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-devise | bookworm | 4.8.1-1 | fixed |
| Ubuntu | gitlab | 16.04 | 8.4.3+dfsg-9 | vulnerable |
| Ubuntu | gitlab | 16.04 | 8.4.3+dfsg-12 | vulnerable |
| Ubuntu | gitlab | 16.04 | 8.5.8+dfsg-5 | vulnerable |
| Ubuntu | ruby-devise | 18.04 | 4.2.0-1 | vulnerable |
| Ubuntu | ruby-devise | 18.04 | 4.3.0-1 | vulnerable |
| Ubuntu | ruby-devise | 18.04 | 4.4.3-1 | vulnerable |
| Ubuntu | ruby-devise | 20.04 | 4.5.0-3 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-devise | source | bookworm | 4.5.0-3 | not yet assigned | Not reported | [926348] |
| Ubuntu | ruby-devise | deb | 20.04 | 4.5.0-3 | Not reported | UBUNTU-CVE-2019-5421 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-devise]Fixed
Details (2)
4.8.1-1· all · bookwormFixed · Fixed:
4.5.0-3dsa · ruby-devise · debian · bookworm; dsa · ruby-devise · debian · 12
4.8.1-1· all · bookwormFixed · Fixed:
4.5.0-3dsa · ruby-devise · debian · bookworm; dsa · ruby-devise · debian · 12
Observed: