
CVE catalog
CVE-2020-11020
ruby-faye: CVE-2020-11020
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.57% · Oct 25, 2026
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-faye | bookworm | 1.4.0-1 | fixed |
| Ubuntu | ruby-faye | 20.04 | 1.2.4-1 | vulnerable |
| Ubuntu | ruby-faye | 22.04 | 1.4.0-1 | vulnerable |
| Ubuntu | ruby-faye | 24.04 | 1.4.0-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-faye | source | bookworm | 1.4.0-1 | not yet assigned | Not reported | [959392] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-faye]Fixed
Details (2)
1.4.0-1· all · bookwormFixed · Fixed:
1.4.0-1dsa · ruby-faye · debian · bookworm; dsa · ruby-faye · debian · 12
1.4.0-1· all · bookwormFixed · Fixed:
1.4.0-1dsa · ruby-faye · debian · bookworm; dsa · ruby-faye · debian · 12
Observed: