
CVE catalog
CVE-2020-11054
qutebrowser: CVE-2020-11054
- Severity
- Low · CVSS 3.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.51% · Oct 25, 2026
In qutebrowser versions less than 1.11.1, reloading a page with certificate errors shows a green URL. After a certificate error was overridden by the user, qutebrowser displays the URL as yellow (colors.statusbar.url.warn.fg). However, when the affected website was subsequently loaded again, the URL was mistakenly displayed as green (colors.statusbar.url.success_https). While the user already has seen a certificate error prompt at this point (or set content.ssl_strict to false, which is not recommended), this could still provide a false sense of security. This has been fixed in 1.11.1 and 1.12.0. All versions of qutebrowser are believed to be affected, though versions before v0.11.x couldn't be tested. Backported patches for older versions (greater than or equal to 1.4.0 and less than or equal to 1.10.2) are available, but no further releases are planned.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | qutebrowser | sid | 3.7.0-1 | fixed |
| Debian | qutebrowser | forky | 3.7.0-1 | fixed |
| Debian | qutebrowser | trixie | 3.4.0-1 | fixed |
| Debian | qutebrowser | bookworm | 2.5.3-1 | fixed |
| Ubuntu | qutebrowser | 18.04 | 0.11.0-1 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.0.4-1 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.0.4-2 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.0.4-3 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.1.0-1 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.1.1-1 | vulnerable |
| Ubuntu | qutebrowser | 18.04 | 1.1.1-1ubuntu0.1 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.7.0-1 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.8.1-2 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.8.3-1 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.9.0-1 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.10.0-1 | vulnerable |
| Ubuntu | qutebrowser | 20.04 | 1.10.1-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | qutebrowser | source | sid | 1.11.1.post1-1 | unimportant | Not reported | Not reported |
| Debian | qutebrowser | source | forky | 1.11.1.post1-1 | unimportant | Not reported | Not reported |
| Debian | qutebrowser | source | trixie | 1.11.1.post1-1 | unimportant | Not reported | Not reported |
| Debian | qutebrowser | source | bookworm | 1.11.1.post1-1 | unimportant | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [qutebrowser]Fixed
Details (2)
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
- [qutebrowser-qtwebengine]Fixed
Source package: [qutebrowser]
Details (2)
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
- [qutebrowser-qtwebkit]Fixed
Source package: [qutebrowser]
Details (2)
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
2.5.3-1· all · bookwormFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · bookworm; dsa · qutebrowser · debian · 12
[Debian 13 (Trixie)]
- [qutebrowser]Fixed
Details (2)
3.4.0-1· all · trixieFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · 13
3.4.0-1· all · trixieFixed · Fixed:
1.11.1.post1-1dsa · qutebrowser · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11292-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2020-11054]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2020-11054]
- [https://security-tracker.debian.org/tracker/CVE-2020-11054]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]