
CVE catalog
CVE-2020-15138
node-prismjs: CVE-2020-15138
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.04% · Oct 25, 2026
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-prismjs | sid | 1.30.0+dfsg+~1.26.6-1 | fixed |
| Debian | node-prismjs | forky | 1.30.0+dfsg+~1.26.6-1 | fixed |
| Debian | node-prismjs | trixie | 1.29.0+dfsg+~1.26.0-1 | fixed |
| Debian | node-prismjs | bookworm | 1.29.0+dfsg+~1.26.0-1 | fixed |
| Ubuntu | node-prismjs | 20.04 | 1.11.0+dfsg-2 | vulnerable |
| Ubuntu | node-prismjs | 20.04 | 1.11.0+dfsg-3 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-prismjs | source | sid | 1.11.0+dfsg-4 | not yet assigned | Not reported | [968094] |
| Debian | node-prismjs | source | forky | 1.11.0+dfsg-4 | not yet assigned | Not reported | [968094] |
| Debian | node-prismjs | source | trixie | 1.11.0+dfsg-4 | not yet assigned | Not reported | [968094] |
| Debian | node-prismjs | source | bookworm | 1.11.0+dfsg-4 | not yet assigned | Not reported | [968094] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-prismjs]Fixed
Details (2)
1.29.0+dfsg+~1.26.0-1· all · bookwormFixed · Fixed:
1.11.0+dfsg-4dsa · node-prismjs · debian · bookworm; dsa · node-prismjs · debian · 12
1.29.0+dfsg+~1.26.0-1· all · bookwormFixed · Fixed:
1.11.0+dfsg-4dsa · node-prismjs · debian · bookworm; dsa · node-prismjs · debian · 12
[Debian 13 (Trixie)]
- [node-prismjs]Fixed
Details (2)
1.29.0+dfsg+~1.26.0-1· all · trixieFixed · Fixed:
1.11.0+dfsg-4dsa · node-prismjs · debian · 13
1.29.0+dfsg+~1.26.0-1· all · trixieFixed · Fixed:
1.11.0+dfsg-4dsa · node-prismjs · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2020-15138]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2020-15138]
- [https://security-tracker.debian.org/tracker/CVE-2020-15138]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1350.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database]