CVE catalog

CVE-2020-15177

UBUNTU-CVE-2020-15177

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.77% · Oct 25, 2026

In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Ubuntuglpi16.040.84.8+dfsg.1-1vulnerable
Ubuntuglpi16.040.84.8+dfsg.1-1ubuntu1vulnerable

Fixed-version evidence

OpenFactory catalog packages

No matching packages in this catalog.

Observed:

References