
CVE catalog
CVE-2020-15720
UBUNTU-CVE-2020-15720
- Severity
- Medium · CVSS 6.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.98% · Oct 25, 2026
In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | dogtag-pki | 11 | 10.9.1-1 | fixed |
| Ubuntu | dogtag-pki | pro | 10.3.5+12-4ubuntu1 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.3.5+12-5 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.5.3-3 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.5.3-4 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.5.5-1 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.6.0~beta2-3 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.6.0-1ubuntu1 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.6.0-1ubuntu2 | vulnerable |
| Ubuntu | dogtag-pki | pro | 10.6.0-1ubuntu2+esm1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | dogtag-pki | deb | 11 | 10.9.1-1 | Not reported | DEBIAN-CVE-2020-15720 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: