
CVE catalog
CVE-2020-25630
UBUNTU-CVE-2020-25630
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.36% · Oct 25, 2026
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | moodle | pro | 2.7.9+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.10+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-2 | vulnerable |
| Ubuntu | moodle | pro | 2.7.12+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: