
CVE catalog
CVE-2020-25699
UBUNTU-CVE-2020-25699
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.61% · Oct 25, 2026
In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | moodle | pro | 2.7.9+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.10+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-2 | vulnerable |
| Ubuntu | moodle | pro | 2.7.12+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: