CVE catalog

CVE-2020-5217

ruby-secure-headers: CVE-2020-5217

[CVE catalog]

Severity
Medium · CVSS 5.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
Published
Source
[NVD] · [CVE record]
EPSS
1.83% · Oct 25, 2026

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. If user-supplied input was passed into append/override_content_security_policy_directives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secure_headers are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPT_OUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-secure-headerssid7.3.0-1fixed
Debianruby-secure-headersforky7.3.0-1fixed
Debianruby-secure-headerstrixie6.3.2-2fixed
Debianruby-secure-headersbookworm6.3.2-1fixed
Ubunturuby-secure-headers18.043.7.1-1vulnerable
Ubunturuby-secure-headers20.046.0.0-1vulnerable
Ubunturuby-secure-headers20.046.1.1-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-secure-headerssourcesid6.3.1-1not yet assignedNot reported[949999]
Debianruby-secure-headerssourceforky6.3.1-1not yet assignedNot reported[949999]
Debianruby-secure-headerssourcetrixie6.3.1-1not yet assignedNot reported[949999]
Debianruby-secure-headerssourcebookworm6.3.1-1not yet assignedNot reported[949999]

[Debian bug #949999]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 6.3.2-1 · all · bookworm

      Fixed · Fixed: 6.3.1-1

      dsa · ruby-secure-headers · debian · bookworm; dsa · ruby-secure-headers · debian · 12

    • 6.3.2-1 · all · bookworm

      Fixed · Fixed: 6.3.1-1

      dsa · ruby-secure-headers · debian · bookworm; dsa · ruby-secure-headers · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 6.3.2-2 · all · trixie

      Fixed · Fixed: 6.3.1-1

      dsa · ruby-secure-headers · debian · 13

    • 6.3.2-2 · all · trixie

      Fixed · Fixed: 6.3.1-1

      dsa · ruby-secure-headers · debian · 13

Observed:

References