CVE catalog

CVE-2020-5301

simplesamlphp: CVE-2020-5301

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
0.92% · Oct 25, 2026

SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. The module controller in `SimpleSAML\Module` that processes requests for pages hosted by modules, has code to identify paths ending with `.php` and process those as PHP code. If no other suitable way of handling the given path exists it presents the file to the browser. The check to identify paths ending with `.php` does not account for uppercase letters. If someone requests a path ending with e.g. `.PHP` and the server is serving the code from a case-insensitive file system, such as on Windows, the processing of the PHP code does not occur, and the source code is instead presented to the browser. An attacker may use this issue to gain access to the source code in third-party modules that is meant to be private, or even sensitive. However, the attack surface is considered small, as the attack will only work when SimpleSAMLphp serves such content from a file system that is not case-sensitive, such as on Windows. This issue is fixed in version 1.18.6.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimplesamlphpsid2.5.3.1-1not affected
Debiansimplesamlphpforky2.5.3.1-1not affected
Debiansimplesamlphpbookworm1.19.7-1+deb12u2not affected
Debiansimplesamlphpbookworm-security1.19.7-1+deb12u1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
DebiansimplesamlphpsourcesidNot affectedunimportantNot reportedNot reported
DebiansimplesamlphpsourceforkyNot affectedunimportantNot reportedNot reported
DebiansimplesamlphpsourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [simplesamlphp]Not affected
    Details (4)
    • 1.19.7-1+deb12u2 · all · bookworm

      Not affected

      dsa · simplesamlphp · debian · bookworm

    • 1.19.7-1+deb12u2 · all · bookworm

      Not affected

      dsa · simplesamlphp · debian · bookworm

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Not affected

      dsa · simplesamlphp · debian · bookworm

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Not affected

      dsa · simplesamlphp · debian · bookworm

Observed:

References