CVE catalog

CVE-2020-7676

angular.js: CVE-2020-7676

[CVE catalog]

Severity
Medium · CVSS 5.4CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Published
Source
[NVD] · [CVE record]
EPSS
1.93% · Oct 25, 2026

angular.js prior to 1.8.0 allows cross site scripting. The regex-based input HTML replacement may turn sanitized code into unsanitized one. Wrapping "<option>" elements in "<select>" ones changes parsing behavior, leading to possibly unsanitizing code.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianangular.jssid1.8.3-3fixed
Debianangular.jstrixie1.8.3-3fixed
Debianangular.jsbookworm1.8.3-1+deb12u1fixed
Ubuntuangular.jspro1.5.10-1vulnerable
Ubuntuangular.jspro1.7.9-1vulnerable
Ubuntuangular.jspro1.7.9-1ubuntu0.1~esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianangular.jssourcesid1.8.0-1not yet assignedNot reportedNot reported
Debianangular.jssourcetrixie1.8.0-1not yet assignedNot reportedNot reported
Debianangular.jssourcebookworm1.8.0-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [angular.js]

    Details (2)
    • 1.8.3-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.8.0-1

      dsa · angular.js · debian · bookworm; dsa · angular.js · debian · 12

    • 1.8.3-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.8.0-1

      dsa · angular.js · debian · bookworm; dsa · angular.js · debian · 12

[Debian 13 (Trixie)]

  • Source package: [angular.js]

    Details (2)
    • 1.8.3-3 · all · trixie

      Fixed · Fixed: 1.8.0-1

      dsa · angular.js · debian · 13

    • 1.8.3-3 · all · trixie

      Fixed · Fixed: 1.8.0-1

      dsa · angular.js · debian · 13

Observed:

References