CVE catalog

CVE-2020-7981

ruby-geocoder: CVE-2020-7981

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.48% · Oct 25, 2026

sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when within_bounding_box is used in conjunction with untrusted sw_lat, sw_lng, ne_lat, or ne_lng data.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-geocodersid1.8.6-1fixed
Debianruby-geocoderforky1.8.6-1fixed
Debianruby-geocodertrixie1.5.1-3fixed
Debianruby-geocoderbookworm1.5.1-3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-geocodersourcesid1.5.1-3not yet assignedNot reported[949870]
Debianruby-geocodersourceforky1.5.1-3not yet assignedNot reported[949870]
Debianruby-geocodersourcetrixie1.5.1-3not yet assignedNot reported[949870]
Debianruby-geocodersourcebookworm1.5.1-3not yet assignedNot reported[949870]

[Debian bug #949870]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.5.1-3 · all · bookworm

      Fixed · Fixed: 1.5.1-3

      dsa · ruby-geocoder · debian · bookworm; dsa · ruby-geocoder · debian · 12

    • 1.5.1-3 · all · bookworm

      Fixed · Fixed: 1.5.1-3

      dsa · ruby-geocoder · debian · bookworm; dsa · ruby-geocoder · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.5.1-3 · all · trixie

      Fixed · Fixed: 1.5.1-3

      dsa · ruby-geocoder · debian · 13

    • 1.5.1-3 · all · trixie

      Fixed · Fixed: 1.5.1-3

      dsa · ruby-geocoder · debian · 13

Observed:

References