
CVE catalog
CVE-2021-21238
python-pysaml2: CVE-2021-21238
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.10% · Oct 25, 2026
PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | python-pysaml2 | sid | 7.5.4-3 | fixed |
| Debian | python-pysaml2 | forky | 7.5.4-3 | fixed |
| Debian | python-pysaml2 | trixie | 7.5.0-4 | fixed |
| Debian | python-pysaml2 | bookworm | 7.0.1-2 | fixed |
| Ubuntu | python-pysaml2 | pro | 2.4.0-0ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | pro | 3.0.0-3ubuntu1 | vulnerable |
| Ubuntu | python-pysaml2 | pro | 3.0.0-3ubuntu1.16.04.1 | vulnerable |
| Ubuntu | python-pysaml2 | pro | 3.0.0-3ubuntu1.16.04.3 | vulnerable |
| Ubuntu | python-pysaml2 | pro | 3.0.0-3ubuntu1.16.04.4 | vulnerable |
| Ubuntu | python-pysaml2 | pro | 3.0.0-3ubuntu1.16.04.4+esm1 | vulnerable |
| Ubuntu | python-pysaml2 | 18.04 | 3.0.0-3ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | 18.04 | 4.0.2-0ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | 18.04 | 4.0.2-0ubuntu3 | vulnerable |
| Ubuntu | python-pysaml2 | 18.04 | 4.0.2-0ubuntu3.1 | vulnerable |
| Ubuntu | python-pysaml2 | 18.04 | 4.0.2-0ubuntu3.2 | vulnerable |
| Ubuntu | python-pysaml2 | 20.04 | 4.5.0+dfsg1-0ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | 20.04 | 4.9.0-0ubuntu1 | vulnerable |
| Ubuntu | python-pysaml2 | 20.04 | 4.9.0-0ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | 20.04 | 4.9.0-0ubuntu3 | vulnerable |
| Ubuntu | python-pysaml2 | 20.04 | 4.9.0-0ubuntu3.1 | vulnerable |
| Ubuntu | python-pysaml2 | 22.04 | 6.1.0-0ubuntu2 | vulnerable |
| Ubuntu | python-pysaml2 | 22.04 | 7.1.0-0ubuntu2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | python-pysaml2 | source | sid | 6.5.1-1 | not yet assigned | Not reported | [980773] |
| Debian | python-pysaml2 | source | forky | 6.5.1-1 | not yet assigned | Not reported | [980773] |
| Debian | python-pysaml2 | source | trixie | 6.5.1-1 | not yet assigned | Not reported | [980773] |
| Debian | python-pysaml2 | source | bookworm | 6.5.1-1 | not yet assigned | Not reported | [980773] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-pysaml2]Fixed
Source package: [python-pysaml2]
Details (2)
7.0.1-2· all · bookwormFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · bookworm; dsa · python-pysaml2 · debian · 12
7.0.1-2· all · bookwormFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · bookworm; dsa · python-pysaml2 · debian · 12
- [python-pysaml2-doc]Fixed
Source package: [python-pysaml2]
Details (2)
7.0.1-2· all · bookwormFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · bookworm; dsa · python-pysaml2 · debian · 12
7.0.1-2· all · bookwormFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · bookworm; dsa · python-pysaml2 · debian · 12
[Debian 13 (Trixie)]
- [python3-pysaml2]Fixed
Source package: [python-pysaml2]
Details (2)
7.5.0-4· all · trixieFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · 13
7.5.0-4· all · trixieFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · 13
- [python-pysaml2-doc]Fixed
Source package: [python-pysaml2]
Details (2)
7.5.0-4· all · trixieFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · 13
7.5.0-4· all · trixieFixed · Fixed:
6.5.1-1dsa · python-pysaml2 · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11524-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-21238]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-21238]
- [https://security-tracker.debian.org/tracker/CVE-2021-21238]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]