
CVE catalog
CVE-2021-21240
python-httplib2: CVE-2021-21240
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 3.63% · Oct 27, 2026
httplib2 is a comprehensive HTTP client library for Python. In httplib2 before version 0.19.0, a malicious server which responds with long series of "\xa0" characters in the "www-authenticate" header may cause Denial of Service (CPU burn while parsing header) of the httplib2 client accessing said server. This is fixed in version 0.19.0 which contains a new implementation of auth headers parsing using the pyparsing library.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | python-httplib2 | sid | 0.32.0-1 | fixed |
| Debian | python-httplib2 | forky | 0.32.0-1 | fixed |
| Debian | python-httplib2 | trixie | 0.22.0-1+deb13u1 | fixed |
| Debian | python-httplib2 | trixie-security | 0.22.0-1+deb13u1 | fixed |
| Debian | python-httplib2 | bookworm | 0.20.4-3 | fixed |
| Debian | python-httplib2 | bookworm-security | 0.20.4-3+deb12u1 | fixed |
| Ubuntu | python-httplib2 | 14.04 | 0.8-2 | vulnerable |
| Ubuntu | python-httplib2 | 14.04 | 0.8-2build1 | vulnerable |
| Ubuntu | python-httplib2 | 16.04 | 0.9+dfsg-2 | vulnerable |
| Ubuntu | python-httplib2 | 16.04 | 0.9.1+dfsg-1 | vulnerable |
| Ubuntu | python-httplib2 | 18.04 | 0.9.2+dfsg-1 | vulnerable |
| Ubuntu | python-httplib2 | 18.04 | 0.9.2+dfsg-1ubuntu0.1 | vulnerable |
| Ubuntu | python-httplib2 | 18.04 | 0.9.2+dfsg-1ubuntu0.2 | vulnerable |
| Ubuntu | python-httplib2 | 18.04 | 0.9.2+dfsg-1ubuntu0.3 | vulnerable |
| Ubuntu | python-httplib2 | 20.04 | 0.11.3-2 | vulnerable |
| Ubuntu | python-httplib2 | 20.04 | 0.11.3-2build1 | vulnerable |
| Ubuntu | python-httplib2 | 20.04 | 0.14.0-1 | vulnerable |
| Ubuntu | python-httplib2 | 20.04 | 0.14.0-1ubuntu1 | vulnerable |
| Ubuntu | python-httplib2 | 22.04 | 0.18.1-3ubuntu1 | vulnerable |
| Ubuntu | python-httplib2 | 22.04 | 0.20.2-2 | vulnerable |
| Ubuntu | python-httplib2 | 22.04 | 0.20.2-2ubuntu0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | python-httplib2 | source | sid | 0.20.2-1 | not yet assigned | Not reported | [982738] |
| Debian | python-httplib2 | source | forky | 0.20.2-1 | not yet assigned | Not reported | [982738] |
| Debian | python-httplib2 | source | trixie | 0.20.2-1 | not yet assigned | Not reported | [982738] |
| Debian | python-httplib2 | source | bookworm | 0.20.2-1 | not yet assigned | Not reported | [982738] |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [python3-httplib2]Unknown
Source package: [python-httplib2]
Details (4)
0.20.4-3· all · bookwormFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · bookworm; dsa · python-httplib2 · debian · 12
0.20.4-3· all · bookwormFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · bookworm; dsa · python-httplib2 · debian · 12
0.20.4-3+deb12u1· all · bookworm-securityFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · bookworm; dsa · python-httplib2 · debian · 12
0.20.4-3+deb12u1· all · bookworm-securityFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · bookworm; dsa · python-httplib2 · debian · 12
[Debian 13 (Trixie)]
- [python3-httplib2]Unknown
Source package: [python-httplib2]
Details (4)
0.22.0-1· all · trixieFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · 13
0.22.0-1· all · trixieFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · 13
0.22.0-1+deb13u1· all · trixie-securityFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · 13
0.22.0-1+deb13u1· all · trixie-securityFixed · Fixed:
0.20.2-1dsa · python-httplib2 · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11203-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-21240]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-21240]
- [https://security-tracker.debian.org/tracker/CVE-2021-21240]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-21240.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]