
CVE catalog
CVE-2021-21252
phpmyadmin: CVE-2021-21252
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 3.57% · Oct 25, 2026
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | phpmyadmin | sid | 4:5.2.4~dev~git20260809.e0909b211b+dfsg-1 | fixed |
| Debian | phpmyadmin | forky | 4:5.2.4~dev~git20260809.e0909b211b+dfsg-1 | fixed |
| Debian | phpmyadmin | trixie | 4:5.2.2-really+dfsg-1+deb13u1 | fixed |
| Debian | phpmyadmin | bookworm | 4:5.2.1+dfsg-1+deb12u1 | fixed |
| Ubuntu | phpmyadmin | pro | 4:4.9.1+dfsg1-2 | vulnerable |
| Ubuntu | phpmyadmin | pro | 4:4.9.2+dfsg1-1 | vulnerable |
| Ubuntu | phpmyadmin | pro | 4:4.9.5+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | phpmyadmin | pro | 4:4.9.5+dfsg1-2 | vulnerable |
| Ubuntu | phpmyadmin | pro | 4:4.9.5+dfsg1-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1build1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1ubuntu1+esm1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 4.0.10-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.1-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.1-2 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.2-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.3-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.5-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.6-1 | vulnerable |
| Ubuntu | otrs2 | 16.04 | 5.0.7-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 5.0.23-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 5.0.24-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 6.0.1-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 6.0.2-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 6.0.3-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 6.0.4-1 | vulnerable |
| Ubuntu | otrs2 | 18.04 | 6.0.5-1 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.20-1 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.23-2 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.24-1 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.25-1 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.25-2 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.25-3 | vulnerable |
| Ubuntu | otrs2 | 20.04 | 6.0.26-1 | vulnerable |
| Ubuntu | otrs2 | 22.04 | 6.0.32-6 | vulnerable |
| Ubuntu | otrs2 | 22.04 | 6.1.2-1 | vulnerable |
| Ubuntu | otrs2 | 22.04 | 6.2.1-1 | vulnerable |
| Ubuntu | otrs2 | 22.04 | 6.2.2-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | phpmyadmin | source | sid | 4:5.0.4+dfsg2-2 | not yet assigned | Not reported | Not reported |
| Debian | phpmyadmin | source | forky | 4:5.0.4+dfsg2-2 | not yet assigned | Not reported | Not reported |
| Debian | phpmyadmin | source | trixie | 4:5.0.4+dfsg2-2 | not yet assigned | Not reported | Not reported |
| Debian | phpmyadmin | source | bookworm | 4:5.0.4+dfsg2-2 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [phpmyadmin]Fixed
Details (2)
4:5.2.1+dfsg-1+deb12u1· all · bookwormFixed · Fixed:
4:5.0.4+dfsg2-2dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12
4:5.2.1+dfsg-1+deb12u1· all · bookwormFixed · Fixed:
4:5.0.4+dfsg2-2dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12
[Debian 13 (Trixie)]
- [phpmyadmin]Fixed
Details (2)
4:5.2.2-really+dfsg-1+deb13u1· all · trixieFixed · Fixed:
4:5.0.4+dfsg2-2dsa · phpmyadmin · debian · 13
4:5.2.2-really+dfsg-1+deb13u1· all · trixieFixed · Fixed:
4:5.0.4+dfsg2-2dsa · phpmyadmin · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-21252]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-21252]
- [https://security-tracker.debian.org/tracker/CVE-2021-21252]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-21252.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]