
CVE catalog
CVE-2021-21295
Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 18.89% · Oct 25, 2026
Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel's pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | fixed |
| Debian | netty | forky | 1:4.1.48-16 | fixed |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | fixed |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | fixed |
| Cpe | netty | Not reported | 4.1.60 | fixed |
| Cpe | oncommand_api_services | Not reported | Not reported | unknown |
| Cpe | oncommand_workflow_automation | Not reported | Not reported | unknown |
| Cpe | debian_linux | Not reported | Not reported | unknown |
| Cpe | quarkus | Not reported | Not reported | unknown |
| Cpe | kudu | Not reported | 1.16.0 | fixed |
| Cpe | zookeeper | Not reported | Not reported | unknown |
| Cpe | communications_cloud_native_core_policy | Not reported | Not reported | unknown |
| Ubuntu | netty | pro | 1:4.1.33-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-2 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-3 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm1 | fixed |
| Ubuntu | netty | 22.04 | 1:4.1.48-4 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4+deb11u1build0.22.04.1 | fixed |
| Opensuse | netty | leap 15.2 | 4.1.13-lp152.3.3.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | 1:4.1.48-3 | not yet assigned | Not reported | [984948] |
| Debian | netty | source | forky | 1:4.1.48-3 | not yet assigned | Not reported | [984948] |
| Debian | netty | source | trixie | 1:4.1.48-3 | not yet assigned | Not reported | [984948] |
| Debian | netty | source | bookworm | 1:4.1.48-3 | not yet assigned | Not reported | [984948] |
| Cpe | netty | cpe | Not reported | 4.1.60 | Not reported | NVD-CVE-2021-21295 | Not reported |
| Cpe | kudu | cpe | Not reported | 1.16.0 | Not reported | NVD-CVE-2021-21295 | Not reported |
| Ubuntu | netty | deb | pro | 1:4.1.45-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2021-21295 | Not reported |
| Ubuntu | netty | deb | 22.04 | 1:4.1.48-4+deb11u1build0.22.04.1 | Not reported | UBUNTU-CVE-2021-21295 | Not reported |
| Opensuse | netty | rpm | leap 15.2 | 4.1.13-lp152.3.3.1 | Not reported | OPENSUSE-SU-2021:0448-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [libnetty-java]Unknown
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-3nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-3nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-3nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-3nvd · netty · debian · bookworm; nvd · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Unknown
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieFixed · Fixed:
1:4.1.48-3nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieFixed · Fixed:
1:4.1.48-3nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityFixed · Fixed:
1:4.1.48-3nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityFixed · Fixed:
1:4.1.48-3nvd · netty · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2022_1271-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2021-21295]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-21295]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-21295]
- [https://osv.dev/vulnerability/openSUSE-SU-2021:0448-1]
- [https://security-tracker.debian.org/tracker/CVE-2021-21295]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-21295.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2024/wid-sec-w-2024-0794.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]