
CVE catalog
CVE-2021-21305
CarrierWave vulnerabilities
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 12.68% · Oct 25, 2026
CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-carrierwave | bookworm | 1.3.2-2 | fixed |
| Ubuntu | ruby-carrierwave | noble | 1.3.2-2ubuntu0.24.04.1~esm1 | fixed |
| Ubuntu | ruby-carrierwave | pro | 1.3.2-2 | vulnerable |
| Ubuntu | ruby-carrierwave | pro | 1.3.2-2ubuntu0.24.04.1~esm1 | fixed |
| Ubuntu | ruby-carrierwave | 16.04 | 0.10.0+gh-1 | vulnerable |
| Ubuntu | ruby-carrierwave | 16.04 | 0.10.0+gh-2 | vulnerable |
| Ubuntu | ruby-carrierwave | pro | 1.3.1-2 | vulnerable |
| Ubuntu | ruby-carrierwave | pro | 1.3.1-2ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-carrierwave | source | bookworm | 1.3.2-1 | not yet assigned | Not reported | [982551] |
| Ubuntu | ruby-carrierwave | deb | noble | 1.3.2-2ubuntu0.24.04.1~esm1 | Not reported | Not reported | Not reported |
| Ubuntu | ruby-carrierwave | deb | pro | 1.3.2-2ubuntu0.24.04.1~esm1 | Not reported | USN-7497-1 | Not reported |
| Ubuntu | ruby-carrierwave | deb | pro | 1.3.1-2ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2021-21305 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-carrierwave]Fixed
Details (2)
1.3.2-2· all · bookwormFixed · Fixed:
1.3.2-1usn · ruby-carrierwave · debian · bookworm; usn · ruby-carrierwave · debian · 12
1.3.2-2· all · bookwormFixed · Fixed:
1.3.2-1usn · ruby-carrierwave · debian · bookworm; usn · ruby-carrierwave · debian · 12
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-21305]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-21305]
- [https://osv.dev/vulnerability/USN-7497-1]
- [https://security-tracker.debian.org/tracker/CVE-2021-21305]
- [https://ubuntu.com/security/notices/USN-7497-1]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Ubuntu Security Notices (USN)]