CVE catalog

CVE-2021-21306

node-marked: CVE-2021-21306

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
2.46% · Oct 25, 2026

Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-markedsid18.1.1+~cs7.2.18-1not affected
Debiannode-markedforky18.1.1+~cs7.2.18-1not affected
Debiannode-markedtrixie4.2.3+ds+~4.0.7-4not affected
Debiannode-markedbookworm4.2.3+ds+~4.0.7-2not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-markedsourcesidNot affectedunimportantNot reportedNot reported
Debiannode-markedsourceforkyNot affectedunimportantNot reportedNot reported
Debiannode-markedsourcetrixieNot affectedunimportantNot reportedNot reported
Debiannode-markedsourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libjs-marked]Not affected

    Source package: [node-marked]

    Details (2)
    • 4.2.3+ds+~4.0.7-2 · all · bookworm

      Not affected

      dsa · node-marked · debian · bookworm

    • 4.2.3+ds+~4.0.7-2 · all · bookworm

      Not affected

      dsa · node-marked · debian · bookworm

  • [node-marked]Not affected
    Details (2)
    • 4.2.3+ds+~4.0.7-2 · all · bookworm

      Not affected

      dsa · node-marked · debian · bookworm

    • 4.2.3+ds+~4.0.7-2 · all · bookworm

      Not affected

      dsa · node-marked · debian · bookworm

Observed:

References