
CVE catalog
CVE-2021-21391
UBUNTU-CVE-2021-21391
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.67% · Oct 25, 2026
CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | ckeditor3 | 18.04 | 3.6.6.1+dfsg-1 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-3 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-4 | vulnerable |
| Ubuntu | ckeditor3 | 22.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ckeditor3 | 24.04 | 3.6.6.1+dfsg-7 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: