CVE catalog

CVE-2021-23556

guake: CVE-2021-23556

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.13% · Oct 27, 2026

The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianguakesid3.10.1-1fixed
Debianguakeforky3.10.1-1fixed
Debianguaketrixie3.10-2fixed
Debianguakebookworm3.9.0-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianguakesourcesid3.8.5-1not yet assignedNot reportedNot reported
Debianguakesourceforky3.8.5-1not yet assignedNot reportedNot reported
Debianguakesourcetrixie3.8.5-1not yet assignedNot reportedNot reported
Debianguakesourcebookworm3.8.5-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [guake]Fixed
    Details (2)
    • 3.9.0-2 · all · bookworm

      Fixed · Fixed: 3.8.5-1

      dsa · guake · debian · bookworm; dsa · guake · debian · 12

    • 3.9.0-2 · all · bookworm

      Fixed · Fixed: 3.8.5-1

      dsa · guake · debian · bookworm; dsa · guake · debian · 12

[Debian 13 (Trixie)]

  • [guake]Fixed
    Details (2)
    • 3.10-2 · all · trixie

      Fixed · Fixed: 3.8.5-1

      dsa · guake · debian · 13

    • 3.10-2 · all · trixie

      Fixed · Fixed: 3.8.5-1

      dsa · guake · debian · 13

Observed:

References