
CVE catalog
CVE-2021-29471
UBUNTU-CVE-2021-29471
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.65% · Oct 25, 2026
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.33.2 "Push rules" can specify conditions under which they will match, including `event_match`, which matches event content against a pattern including wildcards. Certain patterns can cause very poor performance in the matching engine, leading to a denial-of-service when processing moderate length events. The issue is patched in version 1.33.2. A potential workaround might be to prevent users from making custom push rules, by blocking such requests at a reverse-proxy.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | matrix-synapse | pro | 0.19.2+dfsg-6 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm4 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.3.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.4.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.3-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.8.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.39.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.48.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.51.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.52.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1ubuntu0.1~esm2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: