
CVE catalog
CVE-2021-32617
exiv2: CVE-2021-32617
- Severity
- Medium · CVSS 6.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.17% · Oct 25, 2026
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An inefficient algorithm (quadratic complexity) was found in Exiv2 versions v0.27.3 and earlier. The inefficient algorithm is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.4. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `rm`.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | exiv2 | sid | 0.28.9+dfsg-1 | fixed |
| Debian | exiv2 | forky | 0.28.9+dfsg-1 | fixed |
| Debian | exiv2 | trixie | 0.28.5+dfsg-1 | fixed |
| Debian | exiv2 | bookworm | 0.27.6-1 | fixed |
| Ubuntu | exiv2 | pro | 0.25-1ubuntu1 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.1 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.2 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.3 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.4 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.5 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.6 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.7+esm1 | vulnerable |
| Ubuntu | exiv2 | pro | 0.25-2.1ubuntu16.04.7+esm2 | fixed |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.1 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.2 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.3 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.4 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.5 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.7 | vulnerable |
| Ubuntu | exiv2 | 18.04 | 0.25-3.1ubuntu0.18.04.9 | fixed |
| Ubuntu | exiv2 | 20.04 | 0.25-4ubuntu2 | vulnerable |
| Ubuntu | exiv2 | 20.04 | 0.25-4ubuntu3 | vulnerable |
| Ubuntu | exiv2 | 20.04 | 0.27.2-8ubuntu2 | vulnerable |
| Ubuntu | exiv2 | 20.04 | 0.27.2-8ubuntu2.2 | vulnerable |
| Ubuntu | exiv2 | 20.04 | 0.27.2-8ubuntu2.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | exiv2 | source | sid | 0.27.5-1 | not yet assigned | Not reported | [988731] |
| Debian | exiv2 | source | forky | 0.27.5-1 | not yet assigned | Not reported | [988731] |
| Debian | exiv2 | source | trixie | 0.27.5-1 | not yet assigned | Not reported | [988731] |
| Debian | exiv2 | source | bookworm | 0.27.5-1 | not yet assigned | Not reported | [988731] |
| Ubuntu | exiv2 | deb | pro | 0.25-2.1ubuntu16.04.7+esm2 | Not reported | UBUNTU-CVE-2021-32617 | Not reported |
| Ubuntu | exiv2 | deb | 18.04 | 0.25-3.1ubuntu0.18.04.9 | Not reported | UBUNTU-CVE-2021-32617 | Not reported |
| Ubuntu | exiv2 | deb | 20.04 | 0.27.2-8ubuntu2.4 | Not reported | UBUNTU-CVE-2021-32617 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [exiv2]Fixed
Details (2)
0.27.6-1· amd64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
0.27.6-1· arm64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
- [libexiv2-27]Fixed
Source package: [exiv2]
Details (2)
0.27.6-1· amd64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
0.27.6-1· arm64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
- [libexiv2-dev]Fixed
Source package: [exiv2]
Details (2)
0.27.6-1· amd64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
0.27.6-1· arm64 · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
- [libexiv2-doc]Fixed
Source package: [exiv2]
Details (2)
0.27.6-1· all · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
0.27.6-1· all · bookwormFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · bookworm; dsa · exiv2 · debian · 12
[Debian 13 (Trixie)]
- [exiv2]Fixed
Details (2)
0.28.5+dfsg-1· amd64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
0.28.5+dfsg-1· arm64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
- [libexiv2-28]Fixed
Source package: [exiv2]
Details (2)
0.28.5+dfsg-1· amd64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
0.28.5+dfsg-1· arm64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
- [libexiv2-data]Fixed
Source package: [exiv2]
Details (2)
0.28.5+dfsg-1· all · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
0.28.5+dfsg-1· all · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
- [libexiv2-dev]Fixed
Source package: [exiv2]
Details (2)
0.28.5+dfsg-1· amd64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
0.28.5+dfsg-1· arm64 · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
- [libexiv2-doc]Fixed
Source package: [exiv2]
Details (2)
0.28.5+dfsg-1· all · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
0.28.5+dfsg-1· all · trixieFixed · Fixed:
0.27.5-1dsa · exiv2 · debian · 13
Observed:
References
- [https://access.redhat.com/errata/RHSA-2021:4173]
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2021_4173.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-32617]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-32617]
- [https://security-tracker.debian.org/tracker/CVE-2021-32617]
- [https://wid.cert-bund.de/.well-known/csaf/white/2021/wid-sec-w-2022-1968.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]