
CVE catalog
CVE-2021-32718
rabbitmq-server: CVE-2021-32718
- Severity
- Medium · CVSS 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.43% · Oct 25, 2026
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | fixed |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | fixed |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | fixed |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.2 | fixed |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | forky | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | trixie | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | bookworm | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Ubuntu | rabbitmq-server | deb | 20.04 | 3.8.3-0ubuntu0.2 | Not reported | USN-7143-1 | Not reported |
| Ubuntu | rabbitmq-server | deb | 20.04 | 3.8.3-0ubuntu0.2 | Not reported | UBUNTU-CVE-2021-32718 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Fixed
Details (4)
3.10.8-1.1+deb12u1· all · bookwormFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookwormFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
[Debian 13 (Trixie)]
- [rabbitmq-server]Fixed
Details (2)
4.0.5-6+deb13u2· all · trixieFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-fu-2024_2078-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-32718]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-32718]
- [https://osv.dev/vulnerability/USN-7143-1]
- [https://security-tracker.debian.org/tracker/CVE-2021-32718]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-32718.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2021/wid-sec-w-2022-2258.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]