
CVE catalog
CVE-2021-32719
rabbitmq-server: CVE-2021-32719
- Severity
- Medium · CVSS 4.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.42% · Oct 25, 2026
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper <script> tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the `rabbitmq_federation_management` plugin and use [CLI tools](https://www.rabbitmq.com/cli.html) instead.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rabbitmq-server | sid | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | forky | 4.3.6-1 | fixed |
| Debian | rabbitmq-server | trixie | 4.0.5-6+deb13u2 | fixed |
| Debian | rabbitmq-server | bookworm | 3.10.8-1.1+deb12u1 | fixed |
| Debian | rabbitmq-server | bookworm-security | 3.10.8-1.1+deb12u1 | fixed |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.8-4ubuntu2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.7.18-1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.2 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.3 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.4 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.2-0ubuntu1.5 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.1 | vulnerable |
| Ubuntu | rabbitmq-server | 20.04 | 3.8.3-0ubuntu0.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rabbitmq-server | source | sid | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | forky | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | trixie | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Debian | rabbitmq-server | source | bookworm | 3.9.4-1 | not yet assigned | Not reported | [990524] |
| Ubuntu | rabbitmq-server | deb | 20.04 | 3.8.3-0ubuntu0.2 | Not reported | UBUNTU-CVE-2021-32719 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [rabbitmq-server]Fixed
Details (4)
3.10.8-1.1+deb12u1· all · bookwormFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookwormFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
3.10.8-1.1+deb12u1· all · bookworm-securityFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · bookworm; dsa · rabbitmq-server · debian · 12
[Debian 13 (Trixie)]
- [rabbitmq-server]Fixed
Details (2)
4.0.5-6+deb13u2· all · trixieFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · 13
4.0.5-6+deb13u2· all · trixieFixed · Fixed:
3.9.4-1dsa · rabbitmq-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-fu-2024_2078-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-32719]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-32719]
- [https://security-tracker.debian.org/tracker/CVE-2021-32719]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-32719.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2021/wid-sec-w-2022-2258.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]