CVE catalog

CVE-2021-32808

ckeditor: CVE-2021-32808

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.19% · Oct 25, 2026

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianckeditorbookworm4.19.1+dfsg-1fixed
Ubuntuckeditor18.044.5.7+dfsg-2vulnerable
Ubuntuckeditor18.044.5.7+dfsg-2ubuntu0.18.04.1fixed
Ubuntuckeditor20.044.11.1+dfsg-1vulnerable
Ubuntuckeditor20.044.12.1+dfsg-1vulnerable
Ubuntuckeditor20.044.12.1+dfsg-1ubuntu0.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianckeditorsourcebookworm4.16.2+dfsg-1not yet assignedNot reported[992292]
Ubuntuckeditordeb18.044.5.7+dfsg-2ubuntu0.18.04.1Not reportedUSN-5340-1Not reported
Ubuntuckeditordeb20.044.12.1+dfsg-1ubuntu0.1Not reportedUSN-5340-1Not reported

[Debian bug #992292]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ckeditor]Fixed
    Details (2)
    • 4.19.1+dfsg-1 · all · bookworm

      Fixed · Fixed: 4.16.2+dfsg-1

      dsa · ckeditor · debian · bookworm; dsa · ckeditor · debian · 12

    • 4.19.1+dfsg-1 · all · bookworm

      Fixed · Fixed: 4.16.2+dfsg-1

      dsa · ckeditor · debian · bookworm; dsa · ckeditor · debian · 12

Observed:

References