CVE catalog

CVE-2021-3515

pglogical: CVE-2021-3515

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.46% · Oct 25, 2026

A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpglogicalsid2.4.8-2fixed
Debianpglogicalforky2.4.8-2fixed
Debianpglogicaltrixie2.4.5-1fixed
Debianpglogicalbookworm2.4.2-3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpglogicalsourcesid2.3.3-3not yet assignedNot reported[988735]
Debianpglogicalsourceforky2.3.3-3not yet assignedNot reported[988735]
Debianpglogicalsourcetrixie2.3.3-3not yet assignedNot reported[988735]
Debianpglogicalsourcebookworm2.3.3-3not yet assignedNot reported[988735]

[Debian bug #988735]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [pglogical]

    Details (2)
    • 2.4.2-3 · amd64 · bookworm

      Fixed · Fixed: 2.3.3-3

      dsa · pglogical · debian · bookworm; dsa · pglogical · debian · 12

    • 2.4.2-3 · arm64 · bookworm

      Fixed · Fixed: 2.3.3-3

      dsa · pglogical · debian · bookworm; dsa · pglogical · debian · 12

[Debian 13 (Trixie)]

  • Source package: [pglogical]

    Details (2)
    • 2.4.5-1 · amd64 · trixie

      Fixed · Fixed: 2.3.3-3

      dsa · pglogical · debian · 13

    • 2.4.5-1 · arm64 · trixie

      Fixed · Fixed: 2.3.3-3

      dsa · pglogical · debian · 13

Observed:

References