
CVE catalog
CVE-2021-37695
ckeditor: CVE-2021-37695
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.32% · Oct 25, 2026
ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Fake Objects](https://ckeditor.com/cke4/addon/fakeobjects) package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version < 4.16.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ckeditor | bookworm | 4.19.1+dfsg-1 | fixed |
| Debian | ckeditor3 | bookworm | 3.6.6.1+dfsg-7 | not affected |
| Ubuntu | ckeditor | pro | 4.4.4+dfsg1-3 | vulnerable |
| Ubuntu | ckeditor | pro | 4.5.6+dfsg-1 | vulnerable |
| Ubuntu | ckeditor | pro | 4.5.7+dfsg-1 | vulnerable |
| Ubuntu | ckeditor | pro | 4.5.7+dfsg-2 | vulnerable |
| Ubuntu | ckeditor | pro | 4.5.7+dfsg-2ubuntu0.16.04.1~esm1 | fixed |
| Ubuntu | ldap-account-manager | 16.04 | 4.9-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.11-2 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-3 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-4 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-5 | vulnerable |
| Ubuntu | ckeditor | 18.04 | 4.5.7+dfsg-2 | vulnerable |
| Ubuntu | ckeditor | 18.04 | 4.5.7+dfsg-2ubuntu0.18.04.1 | fixed |
| Ubuntu | ckeditor3 | 18.04 | 3.6.6.1+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 5.7-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.1-5 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | ckeditor | 20.04 | 4.11.1+dfsg-1 | vulnerable |
| Ubuntu | ckeditor | 20.04 | 4.12.1+dfsg-1 | vulnerable |
| Ubuntu | ckeditor | 20.04 | 4.12.1+dfsg-1ubuntu0.1 | fixed |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-3 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-4 | vulnerable |
| Ubuntu | ldap-account-manager | 20.04 | 6.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2+deb10u3build0.20.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 22.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.5-1 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1.22.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 24.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.3-1 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.5-1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu2 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.7+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 25.10 | 9.0-1 | vulnerable |
| Ubuntu | request-tracker4 | 25.10 | 4.4.7+dfsg-4syncable1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1build1 | vulnerable |
| Ubuntu | request-tracker4 | 26.04 | 4.4.7+dfsg-4syncable1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ckeditor | source | bookworm | 4.16.2+dfsg-1 | not yet assigned | Not reported | [992290] |
| Debian | ckeditor3 | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Ubuntu | ckeditor | deb | pro | 4.5.7+dfsg-2ubuntu0.16.04.1~esm1 | Not reported | UBUNTU-CVE-2021-37695 | Not reported |
| Ubuntu | ckeditor | deb | 18.04 | 4.5.7+dfsg-2ubuntu0.18.04.1 | Not reported | UBUNTU-CVE-2021-37695 | Not reported |
| Ubuntu | ckeditor | deb | 20.04 | 4.12.1+dfsg-1ubuntu0.1 | Not reported | UBUNTU-CVE-2021-37695 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ckeditor]Fixed
Details (2)
4.19.1+dfsg-1· all · bookwormFixed · Fixed:
4.16.2+dfsg-1dsa · ckeditor · debian · bookworm; dsa · ckeditor · debian · 12
4.19.1+dfsg-1· all · bookwormFixed · Fixed:
4.16.2+dfsg-1dsa · ckeditor · debian · bookworm; dsa · ckeditor · debian · 12
- [ckeditor3]Not affected
Details (2)
3.6.6.1+dfsg-7· all · bookwormNot affected
dsa · ckeditor3 · debian · bookworm
3.6.6.1+dfsg-7· all · bookwormNot affected
dsa · ckeditor3 · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-37695]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-37695]
- [https://security-tracker.debian.org/tracker/CVE-2021-37695]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1030.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database]