CVE catalog

CVE-2021-3882

LedgerSMB vulnerabilities

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.13% · Oct 25, 2026

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianledgersmbbookworm1.6.33+ds-2.1not affected
Ubuntuledgersmbnoble1.6.33+ds-2.1ubuntu0.1fixed
Ubuntuledgersmbpro1.6.9+ds-1vulnerable
Ubuntuledgersmbpro1.6.9+ds-1ubuntu0.1vulnerable
Ubuntuledgersmbpro1.6.9+ds-1ubuntu0.1+esm1fixed
Ubuntuledgersmb22.041.6.9+ds-2.1vulnerable
Ubuntuledgersmb22.041.6.33+ds-1vulnerable
Ubuntuledgersmb22.041.6.33+ds-1ubuntu0.1fixed
Ubuntuledgersmb24.041.6.33+ds-2.1vulnerable
Ubuntuledgersmb24.041.6.33+ds-2.1ubuntu0.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
DebianledgersmbsourcebookwormNot affectedunimportantNot reportedNot reported
Ubuntuledgersmbdebnoble1.6.33+ds-2.1ubuntu0.1Not reportedNot reportedNot reported
Ubuntuledgersmbdebpro1.6.9+ds-1ubuntu0.1+esm1Not reportedUBUNTU-CVE-2021-3882Not reported
Ubuntuledgersmbdeb22.041.6.33+ds-1ubuntu0.1Not reportedUBUNTU-CVE-2021-3882Not reported
Ubuntuledgersmbdeb24.041.6.33+ds-2.1ubuntu0.1Not reportedUBUNTU-CVE-2021-3882Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ledgersmb]Not affected
    Details (2)
    • 1.6.33+ds-2.1 · all · bookworm

      Not affected

      usn · ledgersmb · debian · bookworm

    • 1.6.33+ds-2.1 · all · bookworm

      Not affected

      usn · ledgersmb · debian · bookworm

Observed:

References