
CVE catalog
CVE-2021-39164
UBUNTU-CVE-2021-39164
- Severity
- Low · CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.45% · Oct 25, 2026
Matrix is an ecosystem for open federated Instant Messaging and Voice over IP. In versions 1.41.0 and prior, unauthorised users can access the membership (list of members, with their display names) of a room if they know the ID of the room. The vulnerability is limited to rooms with `shared` history visibility. Furthermore, the unauthorised user must be using an account on a vulnerable homeserver that is in the room. Server administrators should upgrade to 1.41.1 or later in order to receive the patch. One workaround is available. Administrators of servers that use a reverse proxy could, with potentially unacceptable loss of functionality, block the endpoints: `/_matrix/client/r0/rooms/{room_id}/members` with `at` query parameter, and `/_matrix/client/unstable/rooms/{room_id}/members` with `at` query parameter.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | matrix-synapse | pro | 0.19.2+dfsg-6 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm4 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.3.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.4.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.3-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.8.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.39.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.48.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.51.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.52.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1ubuntu0.1~esm2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: