
CVE catalog
CVE-2021-41098
ruby-nokogiri: CVE-2021-41098
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.46% · Oct 25, 2026
Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default. Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected: Nokogiri::XML::SAX::Parse, Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser, Nokogiri::XML::SAX::PushParser, and Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser. JRuby users should upgrade to Nokogiri v1.12.5 or later to receive a patch for this issue. There are no workarounds available for v1.12.4 or earlier. CRuby users are not affected.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-nokogiri | sid | 1.19.4+dfsg-1 | not affected |
| Debian | ruby-nokogiri | forky | 1.19.4+dfsg-1 | not affected |
| Debian | ruby-nokogiri | trixie | 1.18.2+dfsg-1 | not affected |
| Debian | ruby-nokogiri | bookworm | 1.13.10+dfsg-2 | not affected |
| Opensuse | rubygem-nokogiri | tumbleweed | 1.12.5-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-nokogiri | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | ruby-nokogiri | source | forky | Not affected | unimportant | Not reported | Not reported |
| Debian | ruby-nokogiri | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | ruby-nokogiri | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Opensuse | rubygem-nokogiri | rpm | tumbleweed | 1.12.5-1.1 | Not reported | OPENSUSE-SU-2024:11577-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [ruby4.0-rubygem-nokogiri]Unknown
Source package: [rubygem-nokogiri]
Details (1)
1.19.4-1.3· x86_64 · tumbleweedUnknown · Fixed:
1.12.5-1.1Version impact unknown
dsa · rubygem-nokogiri · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [ruby-nokogiri]Not affected
Source package: [ruby-nokogiri]
Details (2)
1.13.10+dfsg-2+b1· amd64 · bookwormNot affected
dsa · ruby-nokogiri · debian · bookworm
1.13.10+dfsg-2+b1· arm64 · bookwormNot affected
dsa · ruby-nokogiri · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11577-1.json]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:11577-1]
- [https://security-tracker.debian.org/tracker/CVE-2021-41098]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-41098.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]