
CVE catalog
CVE-2021-41125
Scrapy vulnerabilities
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.26% · Oct 25, 2026
Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | python-scrapy | sid | 2.19.0-2 | fixed |
| Debian | python-scrapy | forky | 2.19.0-2 | fixed |
| Debian | python-scrapy | trixie | 2.12.0-2 | fixed |
| Debian | python-scrapy | bookworm | 2.8.0-2 | fixed |
| Ubuntu | python-scrapy | noble | 2.11.1-1ubuntu0.1~esm2 | fixed |
| Ubuntu | python-scrapy-doc | noble | 2.11.1-1ubuntu0.1~esm2 | fixed |
| Ubuntu | python3-scrapy | noble | 2.11.1-1ubuntu0.1~esm2 | fixed |
| Ubuntu | python-scrapy | pro | 2.10.0-1 | vulnerable |
| Ubuntu | python-scrapy | pro | 2.11.0-1 | vulnerable |
| Ubuntu | python-scrapy | pro | 2.11.0-2 | vulnerable |
| Ubuntu | python-scrapy | pro | 2.11.1-1 | vulnerable |
| Ubuntu | python-scrapy | pro | 2.11.1-1ubuntu0.1~esm2 | fixed |
| Ubuntu | python-scrapy | 16.04 | 1.0.0-1 | vulnerable |
| Ubuntu | python-scrapy | 16.04 | 1.0.3-1 | vulnerable |
| Ubuntu | python-scrapy | pro | 1.7.3-1 | vulnerable |
| Ubuntu | python-scrapy | pro | 1.7.3-1ubuntu0.1~esm1 | fixed |
| Opensuse | python-Scrapy | tumbleweed | 2.5.1-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | python-scrapy | source | sid | 2.5.1-1 | not yet assigned | Not reported | Not reported |
| Debian | python-scrapy | source | forky | 2.5.1-1 | not yet assigned | Not reported | Not reported |
| Debian | python-scrapy | source | trixie | 2.5.1-1 | not yet assigned | Not reported | Not reported |
| Debian | python-scrapy | source | bookworm | 2.5.1-1 | not yet assigned | Not reported | Not reported |
| Ubuntu | python-scrapy | deb | noble | 2.11.1-1ubuntu0.1~esm2 | Not reported | Not reported | Not reported |
| Ubuntu | python-scrapy-doc | deb | noble | 2.11.1-1ubuntu0.1~esm2 | Not reported | Not reported | Not reported |
| Ubuntu | python3-scrapy | deb | noble | 2.11.1-1ubuntu0.1~esm2 | Not reported | Not reported | Not reported |
| Ubuntu | python-scrapy | deb | pro | 2.11.1-1ubuntu0.1~esm2 | Not reported | USN-7476-1 | Not reported |
| Ubuntu | python-scrapy | deb | pro | 1.7.3-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2021-41125 | Not reported |
| Opensuse | python-Scrapy | rpm | tumbleweed | 2.5.1-1.1 | Not reported | OPENSUSE-SU-2024:11558-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [python313-Scrapy]Unknown
Source package: [python-Scrapy]
Details (1)
2.17.0+git7-1.1· noarch · tumbleweedUnknown · Fixed:
2.5.1-1.1Version impact unknown
usn · python-Scrapy · opensuse · tumbleweed
- [python314-Scrapy]Unknown
Source package: [python-Scrapy]
Details (1)
2.17.0+git7-1.1· noarch · tumbleweedUnknown · Fixed:
2.5.1-1.1Version impact unknown
usn · python-Scrapy · opensuse · tumbleweed
- [python-Scrapy-doc]Unknown
Source package: [python-Scrapy]
Details (1)
2.17.0+git7-1.1· noarch · tumbleweedUnknown · Fixed:
2.5.1-1.1Version impact unknown
usn · python-Scrapy · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [python3-scrapy]Fixed
Source package: [python-scrapy]
Details (2)
2.8.0-2· all · bookwormFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · bookworm; usn · python-scrapy · debian · 12
2.8.0-2· all · bookwormFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · bookworm; usn · python-scrapy · debian · 12
- [python-scrapy-doc]Fixed
Source package: [python-scrapy]
Details (2)
2.8.0-2· all · bookwormFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · bookworm; usn · python-scrapy · debian · 12
2.8.0-2· all · bookwormFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · bookworm; usn · python-scrapy · debian · 12
[Debian 13 (Trixie)]
- [python3-scrapy]Fixed
Source package: [python-scrapy]
Details (2)
2.12.0-2· all · trixieFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · 13
2.12.0-2· all · trixieFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · 13
- [python-scrapy-doc]Fixed
Source package: [python-scrapy]
Details (2)
2.12.0-2· all · trixieFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · 13
2.12.0-2· all · trixieFixed · Fixed:
2.5.1-1usn · python-scrapy · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11558-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-41125]
- [https://osv.dev/vulnerability/DLA-2950-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-41125]
- [https://osv.dev/vulnerability/USN-7476-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:11558-1]
- [https://security-tracker.debian.org/tracker/CVE-2021-41125]
- [https://security.access.redhat.com/data/csaf/v2/vex/2021/cve-2021-41125.json]
- [https://ubuntu.com/security/notices/USN-7476-1]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX] · [Ubuntu Security Notices (USN)]