
CVE catalog
CVE-2021-41164
CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The
- Severity
- High · CVSS 8.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.35% · Oct 25, 2026
CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ckeditor | bookworm | 4.19.1+dfsg-1 | fixed |
| Debian | ckeditor3 | bookworm | 3.6.6.1+dfsg-7 | not affected |
| Cpe | ckeditor | Not reported | 4.17.0 | fixed |
| Cpe | drupal | Not reported | 8.9.20 | fixed |
| Cpe | drupal | Not reported | 9.1.14 | fixed |
| Cpe | drupal | Not reported | 9.2.9 | fixed |
| Cpe | banking_apis | Not reported | Not reported | unknown |
| Cpe | banking_apis | Not reported | Not reported | unknown |
| Cpe | banking_apis | Not reported | Not reported | unknown |
| Cpe | banking_apis | Not reported | Not reported | unknown |
| Cpe | banking_apis | Not reported | Not reported | unknown |
| Cpe | banking_digital_experience | Not reported | Not reported | unknown |
| Cpe | banking_digital_experience | Not reported | Not reported | unknown |
| Cpe | banking_digital_experience | Not reported | Not reported | unknown |
| Cpe | banking_digital_experience | Not reported | Not reported | unknown |
| Cpe | banking_digital_experience | Not reported | Not reported | unknown |
| Cpe | agile_product_lifecycle_management | Not reported | Not reported | unknown |
| Cpe | application_express | Not reported | 22.1 | fixed |
| Cpe | commerce_guided_search | Not reported | Not reported | unknown |
| Cpe | peoplesoft_enterprise_peopletools | Not reported | Not reported | unknown |
| Cpe | peoplesoft_enterprise_peopletools | Not reported | Not reported | unknown |
| Cpe | webcenter_portal | Not reported | Not reported | unknown |
| Ubuntu | ckeditor | pro | 4.16.0+dfsg-2 | vulnerable |
| Ubuntu | ckeditor | pro | 4.16.2+dfsg-1 | vulnerable |
| Ubuntu | ckeditor | pro | 4.16.2+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | ckeditor | pro | 4.16.2+dfsg-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 4.9-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.11-2 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-3 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-4 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-5 | vulnerable |
| Ubuntu | ckeditor3 | 18.04 | 3.6.6.1+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 5.7-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.1-5 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-3 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-4 | vulnerable |
| Ubuntu | ldap-account-manager | 20.04 | 6.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2+deb10u3build0.20.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 22.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.5-1 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1.22.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 24.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.3-1 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.5-1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu2 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.7+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 25.10 | 9.0-1 | vulnerable |
| Ubuntu | request-tracker4 | 25.10 | 4.4.7+dfsg-4syncable1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1build1 | vulnerable |
| Ubuntu | request-tracker4 | 26.04 | 4.4.7+dfsg-4syncable1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ckeditor | source | bookworm | 4.19.0+dfsg-1 | not yet assigned | Not reported | [999909] |
| Debian | ckeditor3 | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | ckeditor | cpe | Not reported | 4.17.0 | Not reported | NVD-CVE-2021-41164 | Not reported |
| Cpe | drupal | cpe | Not reported | 8.9.20 | Not reported | NVD-CVE-2021-41164 | Not reported |
| Cpe | drupal | cpe | Not reported | 9.1.14 | Not reported | NVD-CVE-2021-41164 | Not reported |
| Cpe | drupal | cpe | Not reported | 9.2.9 | Not reported | NVD-CVE-2021-41164 | Not reported |
| Cpe | application_express | cpe | Not reported | 22.1 | Not reported | NVD-CVE-2021-41164 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ckeditor]Fixed
Details (2)
4.19.1+dfsg-1· all · bookwormFixed · Fixed:
4.19.0+dfsg-1nvd · ckeditor · debian · bookworm; nvd · ckeditor · debian · 12
4.19.1+dfsg-1· all · bookwormFixed · Fixed:
4.19.0+dfsg-1nvd · ckeditor · debian · bookworm; nvd · ckeditor · debian · 12
- [ckeditor3]Not affected
Details (2)
3.6.6.1+dfsg-7· all · bookwormNot affected
nvd · ckeditor3 · debian · bookworm
3.6.6.1+dfsg-7· all · bookwormNot affected
nvd · ckeditor3 · debian · bookworm
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2021-41164]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2021-41164]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2021-41164]
- [https://security-tracker.debian.org/tracker/CVE-2021-41164]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]