CVE catalog

CVE-2021-43415

UBUNTU-

[CVE catalog]

HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.

Severity
High · CVSS 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
Updated
Source
[NVD] · [CVE record]
EPSS
1.22% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Ubuntu20.04nomad0.8.7+dfsg1-1ubuntu1UnknownSource applicability is not established[UBUNTU-CVE-2021-43415]
Ubuntu18.04nomad0.4.0+dfsg-1UnknownSource applicability is not established[UBUNTU-CVE-2021-43415]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Ubuntu18.04nomad0.4.0+dfsg-1UnknownSource applicability is not established[UBUNTU-CVE-2021-43415]
Ubuntu20.04nomad0.8.7+dfsg1-1ubuntu1UnknownSource applicability is not established[UBUNTU-CVE-2021-43415]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "nomad",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "18.04",
      "versions": [
        "0.4.0+dfsg-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2021-43415",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2021-43415",
      "provider_updated_at": "2025-10-24T04:50:36Z",
      "applicability_unknown": true
    },
    {
      "name": "nomad",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "20.04",
      "versions": [
        "0.8.7+dfsg1-1ubuntu1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2021-43415",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2021-43415",
      "provider_updated_at": "2025-10-24T04:50:36Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

Observed:

References