CVE catalog

CVE-2021-43809

rubygems: CVE-2021-43809

[CVE catalog]

Severity
High · CVSS 7.3CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
2.91% · Oct 25, 2026

`Bundler` is a package for managing application dependencies in Ruby. In `bundler` versions before 2.2.33, when working with untrusted and apparently harmless `Gemfile`'s, it is not expected that they lead to execution of external code, unless that's explicit in the ruby code inside the `Gemfile` itself. However, if the `Gemfile` includes `gem` entries that use the `git` option with invalid, but seemingly harmless, values with a leading dash, this can be false. To handle dependencies that come from a Git repository instead of a registry, Bundler uses various commands, such as `git clone`. These commands are being constructed using user input (e.g. the repository URL). When building the commands, Bundler versions before 2.2.33 correctly avoid Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. Since this value comes from the `Gemfile` file, it can contain any character, including a leading dash. To exploit this vulnerability, an attacker has to craft a directory containing a `Gemfile` file that declares a dependency that is located in a Git repository. This dependency has to have a Git URL in the form of `-u./payload`. This URL will be used to construct a Git clone command but will be interpreted as the upload-pack argument. Then this directory needs to be shared with the victim, who then needs to run a command that evaluates the Gemfile, such as `bundle lock`, inside. This vulnerability can lead to Arbitrary Code Execution, which could potentially lead to the takeover of the system. However, the exploitability is very low, because it requires a lot of user interaction. Bundler 2.2.33 has patched this problem by inserting `--` as an argument before any positional arguments to those Git commands that were affected by this issue. Regardless of whether users can upgrade or not, they should review any untrustred `Gemfile`'s before running any `bundler` commands that may read them, since they can contain arbitrary ruby code.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianrubygemssid4.0.22-1fixed
Debianrubygemsforky4.0.22-1fixed
Debianrubygemstrixie3.6.7-2fixed
Debianrubygemsbookworm3.3.15-2+deb12u1fixed
Alpineruby-bundler3.152.2.33-r0fixed
Suserubygem-bundlerlinux enterprise module for basesystem 15 sp51.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise module for basesystem 15 sp61.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise server 15 sp2-ltss1.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise server 15 sp3-ltss1.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise server 15 sp4-ltss1.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise server for sap applications 15 sp21.16.1-150000.3.6.1fixed
Suserubygem-bundlerlinux enterprise server for sap applications 15 sp31.16.1-150000.3.6.1fixed
Suserubygem-bundlermanager server 4.31.16.1-150000.3.6.1fixed
Opensuserubygem-bundlerleap 15.51.16.1-150000.3.6.1fixed
Ubuntubundler16.041.10.6-1vulnerable
Ubuntubundler16.041.10.6-2vulnerable
Ubuntubundler16.041.11.2-1vulnerable
Ubuntubundlerpro1.15.1-1vulnerable
Ubuntubundlerpro1.16.1-1vulnerable
Ubuntubundlerpro1.16.1-1ubuntu0.1~esm1vulnerable
Ubuntubundler20.041.17.3-3vulnerable
Ubuntubundler20.042.1.4-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianrubygemssourcesid3.3.5-1not yet assignedNot reportedNot reported
Debianrubygemssourceforky3.3.5-1not yet assignedNot reportedNot reported
Debianrubygemssourcetrixie3.3.5-1not yet assignedNot reportedNot reported
Debianrubygemssourcebookworm3.3.5-1not yet assignedNot reportedNot reported
Alpineruby-bundlerapk3.152.2.33-r0Not reportedALPINE-CVE-2021-43809Not reported
Suserubygem-bundlerrpmlinux enterprise module for basesystem 15 sp51.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise module for basesystem 15 sp61.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise server 15 sp2-ltss1.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise server 15 sp3-ltss1.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise server 15 sp4-ltss1.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise server for sap applications 15 sp21.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmlinux enterprise server for sap applications 15 sp31.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Suserubygem-bundlerrpmmanager server 4.31.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported
Opensuserubygem-bundlerrpmleap 15.51.16.1-150000.3.6.1Not reportedSUSE-SU-2024:3873-1Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [bundler]Fixed

    Source package: [rubygems]

    Details (2)
    • 2.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

    • 2.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

  • Source package: [rubygems]

    Details (2)
    • 2.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

    • 2.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

  • Source package: [rubygems]

    Details (2)
    • 3.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

    • 3.3.15-2+deb12u1 · all · bookworm

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12

[Debian 13 (Trixie)]

  • [bundler]Fixed

    Source package: [rubygems]

    Details (2)
    • 2.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

    • 2.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

  • Source package: [rubygems]

    Details (2)
    • 2.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

    • 2.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

  • Source package: [rubygems]

    Details (2)
    • 3.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

    • 3.6.7-2 · all · trixie

      Fixed · Fixed: 3.3.5-1

      dsa · rubygems · debian · 13

Observed:

References