CVE catalog

CVE-2022-0691

node-url-parse affected and fixed versions

[CVE catalog]

Authorization Bypass Through User-Controlled Key in NPM url-parse prior to 1.5.9.

Severity
Critical · CVSS 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
2.22% · Oct 27, 2026

Projects and upstream resources

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debiantrixienode-url-parse1.5.10+~1.4.8-3Fixed[CVE-2022-0691]
Debiantrixienode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debiansidnode-url-parse1.5.10+~1.4.11-1Fixed[CVE-2022-0691]
Debiansidnode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debianforkynode-url-parse1.5.10+~1.4.11-1Fixed[CVE-2022-0691]
Debianforkynode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debianbookwormnode-url-parse1.5.10+~1.4.8-2Fixed[CVE-2022-0691]
Debianbookwormnode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]

Showing 8 fix observations. All 16 observations, including unknown and conflicting reports, are available below.

Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debianbookwormnode-url-parse1.5.10+~1.4.8-2Fixed[CVE-2022-0691]
Debianbookwormnode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debianforkynode-url-parse1.5.10+~1.4.11-1Fixed[CVE-2022-0691]
Debianforkynode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debiansidnode-url-parse1.5.10+~1.4.11-1Fixed[CVE-2022-0691]
Debiansidnode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Debiantrixienode-url-parse1.5.10+~1.4.8-3Fixed[CVE-2022-0691]
Debiantrixienode-url-parse1.5.9+~1.4.8-1FixedDistribution-reported fixed boundary[CVE-2022-0691]
Ubuntu18.04node-url-parse1.0.5-2UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntu18.04node-url-parse1.2.0-1UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntu18.04node-url-parse1.2.0-1ubuntu0.1UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntu20.04node-url-parse1.4.7-3UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntu20.04node-url-parse1.4.7-3ubuntu0.1UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntupronode-url-parse1.0.5-1UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntupronode-url-parse1.0.5-2UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Ubuntupronode-url-parse1.0.5-2ubuntu0.1~esm2UnknownSource applicability is not established[UBUNTU-CVE-2022-0691]
Original provider fields
{
  "package_releases": [
    {
      "name": "node-url-parse",
      "status": "fixed",
      "release": "sid",
      "version": "1.5.10+~1.4.11-1"
    },
    {
      "name": "node-url-parse",
      "status": "fixed",
      "release": "forky",
      "version": "1.5.10+~1.4.11-1"
    },
    {
      "name": "node-url-parse",
      "status": "fixed",
      "release": "trixie",
      "version": "1.5.10+~1.4.8-3"
    },
    {
      "name": "node-url-parse",
      "status": "fixed",
      "release": "bookworm",
      "version": "1.5.10+~1.4.8-2"
    }
  ],
  "fixed_versions": [
    {
      "bug": null,
      "name": "node-url-parse",
      "type": "source",
      "origin": null,
      "release": "sid",
      "urgency": "not yet assigned",
      "fixed_version": "1.5.9+~1.4.8-1"
    },
    {
      "bug": null,
      "name": "node-url-parse",
      "type": "source",
      "origin": null,
      "release": "forky",
      "urgency": "not yet assigned",
      "fixed_version": "1.5.9+~1.4.8-1"
    },
    {
      "bug": null,
      "name": "node-url-parse",
      "type": "source",
      "origin": null,
      "release": "trixie",
      "urgency": "not yet assigned",
      "fixed_version": "1.5.9+~1.4.8-1"
    },
    {
      "bug": null,
      "name": "node-url-parse",
      "type": "source",
      "origin": null,
      "release": "bookworm",
      "urgency": "not yet assigned",
      "fixed_version": "1.5.9+~1.4.8-1"
    }
  ],
  "distribution_packages": [
    {
      "name": "node-url-parse",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.0.5-2ubuntu0.1~esm2"
            }
          ]
        }
      ],
      "release": "pro",
      "versions": [
        "1.0.5-1",
        "1.0.5-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-0691",
      "fixed_version": "1.0.5-2ubuntu0.1~esm2",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-0691",
      "provider_updated_at": "2026-02-04T02:59:58.640151Z",
      "applicability_unknown": true
    },
    {
      "name": "node-url-parse",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.2.0-1ubuntu0.1"
            }
          ]
        }
      ],
      "release": "18.04",
      "versions": [
        "1.0.5-2",
        "1.2.0-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-0691",
      "fixed_version": "1.2.0-1ubuntu0.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-0691",
      "provider_updated_at": "2026-02-04T02:59:58.640151Z",
      "applicability_unknown": true
    },
    {
      "name": "node-url-parse",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.4.7-3ubuntu0.1"
            }
          ]
        }
      ],
      "release": "20.04",
      "versions": [
        "1.4.7-3"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-0691",
      "fixed_version": "1.4.7-3ubuntu0.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-0691",
      "provider_updated_at": "2026-02-04T02:59:58.640151Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.5.10+~1.4.8-2 · all · bookworm

      Fixed · Fixed: 1.5.9+~1.4.8-1

      dsa · node-url-parse · debian · bookworm

    • 1.5.10+~1.4.8-2 · all · bookworm

      Fixed · Fixed: 1.5.9+~1.4.8-1

      dsa · node-url-parse · debian · bookworm

Observed:

References