CVE catalog

CVE-2022-21222

node-css-what: CVE-2022-21222

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.90% · Oct 25, 2026

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-css-whatsid6.2.2-3fixed
Debiannode-css-whatforky6.2.2-3fixed
Debiannode-css-whattrixie6.1.0-5fixed
Debiannode-css-whatbookworm6.1.0-5fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-css-whatsourcesid5.0.1-1not yet assignedNot reported[1032188]
Debiannode-css-whatsourceforky5.0.1-1not yet assignedNot reported[1032188]
Debiannode-css-whatsourcetrixie5.0.1-1not yet assignedNot reported[1032188]
Debiannode-css-whatsourcebookworm5.0.1-1not yet assignedNot reported[1032188]

[Debian bug #1032188]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 6.1.0-5 · all · bookworm

      Fixed · Fixed: 5.0.1-1

      dsa · node-css-what · debian · bookworm

    • 6.1.0-5 · all · bookworm

      Fixed · Fixed: 5.0.1-1

      dsa · node-css-what · debian · bookworm

Observed:

References