CVE catalog

CVE-2022-21227

node-sqlite3: CVE-2022-21227

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.21% · Oct 25, 2026

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-sqlite3sid6.0.1+ds1-1fixed
Debiannode-sqlite3forky6.0.1+ds1-1fixed
Debiannode-sqlite3trixie5.1.5+ds1-1fixed
Debiannode-sqlite3bookworm5.1.5+ds1-1fixed
Ubuntunode-sqlite316.042.2.0+ds1-1vulnerable
Ubuntunode-sqlite318.043.1.8+ds1-2build1vulnerable
Ubuntunode-sqlite318.043.1.8+ds1-2build2vulnerable
Ubuntunode-sqlite320.044.0.6+ds1-2vulnerable
Ubuntunode-sqlite320.044.1.0+ds1-1vulnerable
Ubuntunode-sqlite320.044.1.1+ds1-1vulnerable
Ubuntunode-sqlite320.044.1.1+ds1-1build1vulnerable
Ubuntunode-sqlite322.045.0.0+ds1-1vulnerable
Ubuntunode-sqlite322.045.0.2+ds1-3vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-sqlite3sourcesid5.0.6+ds1-1not yet assignedNot reportedNot reported
Debiannode-sqlite3sourceforky5.0.6+ds1-1not yet assignedNot reportedNot reported
Debiannode-sqlite3sourcetrixie5.0.6+ds1-1not yet assignedNot reportedNot reported
Debiannode-sqlite3sourcebookworm5.0.6+ds1-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 5.1.5+ds1-1 · amd64 · bookworm

      Fixed · Fixed: 5.0.6+ds1-1

      dsa · node-sqlite3 · debian · bookworm

    • 5.1.5+ds1-1 · arm64 · bookworm

      Fixed · Fixed: 5.0.6+ds1-1

      dsa · node-sqlite3 · debian · bookworm

Observed:

References