
CVE catalog
CVE-2022-21704
node-log4js affected and fixed versions
log4js-node is a port of log4js to node.js. In affected versions default file permissions for log files created by the file, fileSync and dateFile appenders are world-readable (in unix). This could cause problems if log files contain sensitive information. This would affect any users that have not supplied their own permissions for the files via the mode parameter in the config. Users are advised to update.
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.30% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debiantrixie | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debiantrixie | node-log4js | 6.9.1+~cs8.4.19-1 | Fixed | [CVE-2022-21704] |
| Debiansid | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debiansid | node-log4js | 6.9.1+~cs8.4.19-4 | Fixed | [CVE-2022-21704] |
| Debianforky | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debianforky | node-log4js | 6.9.1+~cs8.4.19-4 | Fixed | [CVE-2022-21704] |
| Debianbookworm | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debianbookworm | node-log4js | 6.7.1+~cs8.4.17-1 | Fixed | [CVE-2022-21704] |
Showing 8 fix observations. All 13 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debianbookworm | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debianbookworm | node-log4js | 6.7.1+~cs8.4.17-1 | Fixed | [CVE-2022-21704] |
| Debianforky | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debianforky | node-log4js | 6.9.1+~cs8.4.19-4 | Fixed | [CVE-2022-21704] |
| Debiansid | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debiansid | node-log4js | 6.9.1+~cs8.4.19-4 | Fixed | [CVE-2022-21704] |
| Debiantrixie | node-log4js | 6.4.1+~cs8.3.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-21704] |
| Debiantrixie | node-log4js | 6.9.1+~cs8.4.19-1 | Fixed | [CVE-2022-21704] |
| Ubuntu16.04 | node-log4js | 0.6.18-1 | Affected | [UBUNTU-CVE-2022-21704] |
| Ubuntu18.04 | node-log4js | 0.6.18-1 | Affected | [UBUNTU-CVE-2022-21704] |
| Ubuntu20.04 | node-log4js | 4.5.1-3 | Affected | [UBUNTU-CVE-2022-21704] |
| Ubuntu20.04 | node-log4js | 5.2.1-1 | Affected | [UBUNTU-CVE-2022-21704] |
| Ubuntu20.04 | node-log4js | 6.1.0-1 | Affected | [UBUNTU-CVE-2022-21704] |
Original provider fields
{
"package_releases": [
{
"name": "node-log4js",
"status": "fixed",
"release": "sid",
"version": "6.9.1+~cs8.4.19-4"
},
{
"name": "node-log4js",
"status": "fixed",
"release": "forky",
"version": "6.9.1+~cs8.4.19-4"
},
{
"name": "node-log4js",
"status": "fixed",
"release": "trixie",
"version": "6.9.1+~cs8.4.19-1"
},
{
"name": "node-log4js",
"status": "fixed",
"release": "bookworm",
"version": "6.7.1+~cs8.4.17-1"
}
],
"fixed_versions": [
{
"bug": null,
"name": "node-log4js",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "6.4.1+~cs8.3.5-1"
},
{
"bug": null,
"name": "node-log4js",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "6.4.1+~cs8.3.5-1"
},
{
"bug": null,
"name": "node-log4js",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "6.4.1+~cs8.3.5-1"
},
{
"bug": null,
"name": "node-log4js",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "6.4.1+~cs8.3.5-1"
}
],
"distribution_packages": [
{
"name": "node-log4js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"0.6.18-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-21704",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-21704",
"provider_updated_at": "2025-10-24T04:53:26Z"
},
{
"name": "node-log4js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"0.6.18-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-21704",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-21704",
"provider_updated_at": "2025-10-24T04:53:26Z"
},
{
"name": "node-log4js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "20.04",
"versions": [
"4.5.1-3",
"5.2.1-1",
"6.1.0-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-21704",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-21704",
"provider_updated_at": "2025-10-24T04:53:26Z"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [node-log4js]Unknown
Details (2)
6.7.1+~cs8.4.17-1· all · bookwormFixed · Fixed:
6.4.1+~cs8.3.5-1dsa · node-log4js · debian · bookworm
6.7.1+~cs8.4.17-1· all · bookwormFixed · Fixed:
6.4.1+~cs8.3.5-1dsa · node-log4js · debian · bookworm
Observed: