CVE catalog

CVE-2022-21708

golang-github-graph-gophers-graphql-go: CVE-2022-21708

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.24% · Oct 25, 2026

graphql-go is a GraphQL server with a focus on ease of use. In versions prior to 1.3.0 there exists a DoS vulnerability that is possible due to a bug in the library that would allow an attacker with specifically designed queries to cause stack overflow panics. Any user with access to the GraphQL handler can send these queries and cause stack overflows. This in turn could potentially compromise the ability of the server to serve data to its users. The issue has been patched in version `v1.3.0`. The only known workaround for this issue is to disable the `graphql.MaxDepth` option from your schema which is not recommended.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangolang-github-graph-gophers-graphql-gosid1.10.3-1fixed
Debiangolang-github-graph-gophers-graphql-goforky1.10.3-1fixed
Debiangolang-github-graph-gophers-graphql-gotrixie1.6.0-1fixed
Debiangolang-github-graph-gophers-graphql-gobookworm1.5.0-1fixed
Ubuntugolang-github-graph-gophers-graphql-go20.040.0~git20180609.bb97385-2vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangolang-github-graph-gophers-graphql-gosourcesid1.3.0-1not yet assignedNot reportedNot reported
Debiangolang-github-graph-gophers-graphql-gosourceforky1.3.0-1not yet assignedNot reportedNot reported
Debiangolang-github-graph-gophers-graphql-gosourcetrixie1.3.0-1not yet assignedNot reportedNot reported
Debiangolang-github-graph-gophers-graphql-gosourcebookworm1.3.0-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

Observed:

References