
CVE catalog
CVE-2022-23094
libreswan: CVE-2022-23094
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.54% · Oct 25, 2026
Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libreswan | sid | 5.2-2.5 | fixed |
| Debian | libreswan | forky | 5.2-2.5 | fixed |
| Debian | libreswan | trixie | 5.2-2.2 | fixed |
| Debian | libreswan | bookworm | 4.10-2+deb12u1 | fixed |
| Ubuntu | libreswan | 18.04 | 3.20-7build1 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.21-2 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.22-1 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.22-2 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.22-3 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.22-4 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.23-1 | vulnerable |
| Ubuntu | libreswan | 18.04 | 3.23-4 | vulnerable |
| Ubuntu | libreswan | 20.04 | 3.29-2 | vulnerable |
| Ubuntu | libreswan | 20.04 | 3.29-2build1 | vulnerable |
| Ubuntu | libreswan | 22.04 | 3.32-3ubuntu3 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libreswan | source | sid | 4.6-1 | not yet assigned | Not reported | Not reported |
| Debian | libreswan | source | forky | 4.6-1 | not yet assigned | Not reported | Not reported |
| Debian | libreswan | source | trixie | 4.6-1 | not yet assigned | Not reported | Not reported |
| Debian | libreswan | source | bookworm | 4.6-1 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libreswan]Fixed
Details (2)
4.10-2+deb12u1· amd64 · bookwormFixed · Fixed:
4.6-1dsa · libreswan · debian · bookworm
4.10-2+deb12u1· arm64 · bookwormFixed · Fixed:
4.6-1dsa · libreswan · debian · bookworm
Observed:
References
- [https://access.redhat.com/errata/RHSA-2022:0199]
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2022_0199.json]
- [https://osv.dev/vulnerability/DSA-5048-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23094]
- [https://security-tracker.debian.org/tracker/CVE-2022-23094]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]