CVE catalog

CVE-2022-23220

usbview: CVE-2022-23220

[CVE catalog]

Severity
High · CVSS 8.4CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.50% · Oct 27, 2026

USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianusbviewsid3.1-3fixed
Debianusbviewforky3.1-3fixed
Debianusbviewtrixie3.1-2fixed
Debianusbviewbookworm3.0-3fixed
Ubuntuusbview18.042.0-21-g6fe2f4f-1ubuntu1vulnerable
Ubuntuusbview18.042.0-21-g6fe2f4f-1ubuntu1.1fixed
Ubuntuusbview20.042.0-21-g6fe2f4f-1ubuntu1vulnerable
Ubuntuusbview20.042.0-21-g6fe2f4f-2vulnerable
Ubuntuusbview20.042.0-21-g6fe2f4f-2ubuntu0.20.04.1fixed
Opensuseusbviewtumbleweed3.0-1.1fixed
Ubuntuusbview18.042.0-21-g6fe2f4f-1ubuntu1vulnerable
Ubuntuusbview18.042.0-21-g6fe2f4f-1ubuntu1.1fixed
Ubuntuusbview20.042.0-21-g6fe2f4f-1ubuntu1vulnerable
Ubuntuusbview20.042.0-21-g6fe2f4f-2vulnerable
Ubuntuusbview20.042.0-21-g6fe2f4f-2ubuntu0.20.04.1fixed
Ubuntuusbview22.042.0-21-g6fe2f4f-2vulnerable
Ubuntuusbview22.042.0-21-g6fe2f4f-2ubuntu1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianusbviewsourcesid2.0-21-g6fe2f4f-2.1not yet assignedNot reportedNot reported
Debianusbviewsourceforky2.0-21-g6fe2f4f-2.1not yet assignedNot reportedNot reported
Debianusbviewsourcetrixie2.0-21-g6fe2f4f-2.1not yet assignedNot reportedNot reported
Debianusbviewsourcebookworm2.0-21-g6fe2f4f-2.1not yet assignedNot reportedNot reported
Ubuntuusbviewdeb18.042.0-21-g6fe2f4f-1ubuntu1.1Not reportedUSN-5249-1Not reported
Ubuntuusbviewdeb20.042.0-21-g6fe2f4f-2ubuntu0.20.04.1Not reportedUSN-5249-1Not reported
Opensuseusbviewrpmtumbleweed3.0-1.1Not reportedOPENSUSE-SU-2024:11774-1Not reported
Ubuntuusbviewdeb18.042.0-21-g6fe2f4f-1ubuntu1.1Not reportedUBUNTU-CVE-2022-23220Not reported
Ubuntuusbviewdeb20.042.0-21-g6fe2f4f-2ubuntu0.20.04.1Not reportedUBUNTU-CVE-2022-23220Not reported
Ubuntuusbviewdeb22.042.0-21-g6fe2f4f-2ubuntu1Not reportedUBUNTU-CVE-2022-23220Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [usbview]Fixed
    Details (2)
    • 3.0-3 · amd64 · bookworm

      Fixed · Fixed: 2.0-21-g6fe2f4f-2.1

      dsa · usbview · debian · bookworm

    • 3.0-3 · arm64 · bookworm

      Fixed · Fixed: 2.0-21-g6fe2f4f-2.1

      dsa · usbview · debian · bookworm

[openSUSE Tumbleweed]

  • [usbview]Fixed

    Source package: [usbview]

    Details (1)
    • 3.1-2.4 · x86_64 · tumbleweed

      Fixed · Fixed: 3.0-1.1

      dsa · usbview · opensuse · tumbleweed

Observed:

References