CVE catalog

CVE-2022-23304

wpa_supplicant and hostapd vulnerabilities

[CVE catalog]

Severity
High · CVSS 7.4CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.91% · Oct 25, 2026

The implementations of EAP-pwd in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side-channel attacks as a result of cache access patterns. NOTE: this issue exists because of an incomplete fix for CVE-2019-9495.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianwpasid2:2.11-4fixed
Debianwpaforky2:2.11-4fixed
Debianwpatrixie2:2.10-24fixed
Debianwpabookworm2:2.10-12+deb12u3fixed
Debianwpabookworm-security2:2.10-12+deb12u2fixed
Ubuntuwpanoble2:2.10-21ubuntu0.2fixed
Ubuntueapoltestnoble2:2.10-21ubuntu0.2fixed
Ubuntuhostapdnoble2:2.10-21ubuntu0.2fixed
Ubuntulibwpa-client-devnoble2:2.10-21ubuntu0.2fixed
Ubuntuwpaguinoble2:2.10-21ubuntu0.2fixed
Ubuntuwpasupplicantnoble2:2.10-21ubuntu0.2fixed
Ubuntuwpa20.042:2.9-1ubuntu2vulnerable
Ubuntuwpa20.042:2.9-1ubuntu3vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4.1vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4.2vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4.3vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4.4vulnerable
Ubuntuwpa20.042:2.9-1ubuntu4.6fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianwpasourcesid2:2.10-1not yet assignedNot reportedNot reported
Debianwpasourceforky2:2.10-1not yet assignedNot reportedNot reported
Debianwpasourcetrixie2:2.10-1not yet assignedNot reportedNot reported
Debianwpasourcebookworm2:2.10-1not yet assignedNot reportedNot reported
Ubuntuwpadebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntueapoltestdebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntuhostapddebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntulibwpa-client-devdebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntuwpaguidebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntuwpasupplicantdebnoble2:2.10-21ubuntu0.2Not reportedNot reportedNot reported
Ubuntuwpadeb20.042:2.9-1ubuntu4.6Not reportedUBUNTU-CVE-2022-23304Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [eapoltest]Fixed

    Source package: [wpa]

    Details (4)
    • 2:2.10-12+deb12u3 · amd64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u3 · arm64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

  • [hostapd]Fixed

    Source package: [wpa]

    Details (4)
    • 2:2.10-12+deb12u3 · amd64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u3 · arm64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

  • Source package: [wpa]

    Details (4)
    • 2:2.10-12+deb12u3 · amd64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u3 · arm64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

  • [wpagui]Fixed

    Source package: [wpa]

    Details (4)
    • 2:2.10-12+deb12u3 · amd64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u3 · arm64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

  • Source package: [wpa]

    Details (4)
    • 2:2.10-12+deb12u3 · amd64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u3 · arm64 · bookworm

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

    • 2:2.10-12+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 2:2.10-1

      usn · wpa · debian · bookworm

Observed:

References